Bug 69238 - After trying to connect using SSH to root account, console login crashes
After trying to connect using SSH to root account, console login crashes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: pam (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-19 09:14 EDT by Need Real Name
Modified: 2013-07-02 18:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 04:01:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-19 09:14:48 EDT
Description of Problem:

The arcitecture is the following: I have a Windows 2000 server that I connect 
to using terminal services, and I tried to SSH to the Linux box from there 
using PuTTY. I wait rather long to get password prompt after entering the 
username (root), but the password is not accepted. Furthermore the password is 
no longer accepted even if I try to log from the console. I first suspected an 
intrusion and change of the password, but I finaly got to the cause of the 
problem (and you might guess that this was pretty difficult to debug).

Version-Release number of selected component (if applicable):

RedHat 7.2
kernel-2.4.9-13
openssh-3.1p1-2
Windows 2000 Server w/SP2
Remote Desktop Connection (version from XP)
PuTTY 0.52

How Reproducible:

Each time in my current setup (I haven't tested it too much, though, since this 
requires the reset of the server, which is in production)

Steps to Reproduce:
1. Login to W2k using terminal service (admin mode)
2. Use PuTTY to connect to RedHat 7.2 computer
3. Enter username root
4. Wait for password prompt, then enter password

Actual Results:

Login denied for that session, login denied for all other sessions, including 
direct console login

Expected Results:

Normal login

Additional Information:
	
N/A
Comment 1 Need Real Name 2004-09-21 03:57:57 EDT
After more than two years since reporting the bug I don't remember 
anymore either the solution I've found, or the actual causes of the 
bug. Consider the bug closed.
Comment 2 Jindrich Novy 2004-09-21 04:01:24 EDT
Ok, I'll close the bug, anyway thanks for the report.

Jindrich

Note You need to log in before you can comment on or make changes to this bug.