Bug 69244 - Mount error msg mis-identifies missing file as /dev/fd0
Mount error msg mis-identifies missing file as /dev/fd0
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-19 11:18 EDT by kop
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-19 11:20:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of mount /mnt/floppy (10.11 KB, text/plain)
2002-07-19 11:19 EDT, kop
no flags Details

  None (edit)
Description kop 2002-07-19 11:18:27 EDT
Description of Problem:

I suddenly started to get an error message:

/dev/fd0: No such file or directory

when mounting a floppy.  The strace (attached) seems to indicate
mount is looking for a locale file somewhere in /usr/share,
which I suspect is really the the file that doesn't exist.

The relevant fstab entry is:
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0

The relevant line from mount is:
/dev/fd0 on /mnt/floppy type vfat (rw,nosuid,nodev)


Version-Release number of selected component (if applicable):

mount-2.11g-5

I'm all up to date on updates.

This is a kernel I've compiled myself, but I've never had any
problems with it.  (Well, after umounting the filesystem doesn't reclaim the
storage of a file mounted on the loopback device that's then deleted.
But that's a different problem and seems to have been mentioned on the kernel
mailing lists.)

Linux mofo.meme.com 2.4.17 #2 SMP Wed Mar 20 13:42:50 CST 2002 i686 unknown

I also have devfs turned on. devfsd-1.3.18-1


How Reproducible:

You probably have to have a floppy with some kind of error on it.
Mounting a different floppy does not produce the error.
The last time I umounted the floppy I may have ejected it before
the drive light went off.  (Although I don't beleve I wrote
to the floppy while it was mounted.)


Steps to Reproduce:

mount /mnt/floppy
Comment 1 kop 2002-07-19 11:19:58 EDT
Created attachment 65984 [details]
strace of  mount /mnt/floppy
Comment 2 Elliot Lee 2002-08-08 12:07:55 EDT
1. The absent locale files are unrelated to the problem (they're just used to print out error 
messages in your current language).
2. I can't reproduce the problem with the Limbo beta, so it's likely to be "just you" :)
3. If I had to point a finger, I would blame devfs, which we do not support or include.

Note You need to log in before you can comment on or make changes to this bug.