This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 692465 - Blacklist doesn't work
Blacklist doesn't work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
15
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-31 08:15 EDT by Vít Ondruch
Modified: 2014-02-02 17:15 EST (History)
10 users (show)

See Also:
Fixed In Version: abrt-2.0.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-26 12:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2011-03-31 08:15:19 EDT
Description of problem:
Blacklist doesn't work

How reproducible:


Steps to Reproduce:
1. Following line in /etc/abrt/abrt.conf
   BlackList = nspluginwrapper, valgrind, strace, mono-core, coreutils
2. $ sleep 5m
3. $ pkill -SIGSEGV sleep
  
Actual results:
The error is catched anyway
Comment 1 Michal Nowak 2011-03-31 08:32:43 EDT
I can reproduce it even with strace, which is blacklisted by default. There seems to me some regression in recent week (worked 2 weeks before).
Comment 2 Jiri Moskovcak 2011-03-31 08:39:49 EDT
did you try to restart the daemon?

$ service abrtd restart
Comment 3 Vít Ondruch 2011-03-31 08:52:05 EDT
(In reply to comment #2)
> did you try to restart the daemon?
> 
> $ service abrtd restart

Yes.
Comment 4 Vít Ondruch 2011-03-31 08:53:53 EDT
I see no success yet on Test Day page and Michal can reproduce, so there is probably some issue.
Comment 5 David Kutálek 2011-03-31 10:09:33 EDT
Yep doesn't work for me either. Tried some more combinations of BlakList parameter:

BlackList = coreutils

=>
Mar 31 14:03:48 localhost abrt[6109]: saved core dump of pid 6108 (/bin/sleep) to /var/spool/abrt/ccpp-2011-03-31-14:03:48-6108.new/coredump (339968 bytes)
Mar 31 14:03:48 localhost abrtd: Directory 'ccpp-2011-03-31-14:03:48-6108' creation detected
Mar 31 14:03:48 localhost abrtd: Corrupted or bad dump /var/spool/abrt/ccpp-2011-03-31-14:03:48-6108 (res:2), deleting

BlackList = nspluginwrapper,valgrind,strace,mono-core,coreutils

=> similar result with (res:2), deleting

Michal tells me that (res:2) means blacklisted. If so, it should be more obvious for regular user!
Comment 6 Nikola Pajkovsky 2011-04-06 10:21:55 EDT
(In reply to comment #5)
> =>
> Mar 31 14:03:48 localhost abrt[6109]: saved core dump of pid 6108 (/bin/sleep)
> to /var/spool/abrt/ccpp-2011-03-31-14:03:48-6108.new/coredump (339968 bytes)
> Mar 31 14:03:48 localhost abrtd: Directory 'ccpp-2011-03-31-14:03:48-6108'
> creation detected
> Mar 31 14:03:48 localhost abrtd: Corrupted or bad dump
> /var/spool/abrt/ccpp-2011-03-31-14:03:48-6108 (res:2), deleting
> 
> BlackList = nspluginwrapper,valgrind,strace,mono-core,coreutils
> 
> => similar result with (res:2), deleting
> 
> Michal tells me that (res:2) means blacklisted. If so, it should be more
> obvious for regular user!

Honestly dmesg is not for regular users.

see:
   i801_smbus 0000:00:1f.3: PCI INT A -> GSI 23 (level, low) -> IRQ 23

I don't have any clue, what's going on :)

only the message is a little bit misleading and I'm going to fix it

commit 90fe3a9d0cd766d18d1142d8d6981193a5715643
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon Apr 4 12:02:27 2011 +0200

    rhbz#692465 - Blacklist doesn't work
    
    parse_value() doesn't trim the string.
    
    Lest say BlackList = coreutils, mono
    the parsed list looks like -> 'coreutils', ' mono'
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 7 David Kutálek 2011-04-06 12:26:56 EDT
Hmm, understand your point regarding readability of dmesg. Anyway, it would be usefull to document this behavior somewhere, eg in man for abrt.conf?
Comment 8 Fedora Update System 2011-04-20 09:39:39 EDT
abrt-2.0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-1.fc15
Comment 9 Fedora Update System 2011-04-20 23:06:23 EDT
Package abrt-2.0.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.1-1.fc15
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2011-04-21 12:46:24 EDT
abrt-2.0.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.1-2.fc15
Comment 11 Fedora Update System 2011-04-26 12:13:40 EDT
abrt-2.0.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.