Bug 69262 - xmltex RPM package missing a few files
xmltex RPM package missing a few files
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: xmltex (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-19 14:17 EDT by Jamie Guinan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 16:50:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jamie Guinan 2002-07-19 14:17:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
Package xmltex-20000118-10.noarch.rpm is missing two files,
  /usr/share/texmf/web2c/pdfxmltex.fmt
  /usr/share/texmf/web2c/xmltex.fmt


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. rpm -i xmltex-20000118-10.noarch.rpm 
2. rpm --verify xmltex
3. rpm2cpio xmltex-20000118-10.noarch.rpm | cpio -t


Actual Results:  Files not found.  Running "xmlto pdf foo.xml" fails as a result
with "I can't find the file 'pdfxmltex.fmt'!"


Expected Results:  File should be in cpio / rpm.


Additional info:
Comment 1 Tim Waugh 2002-07-19 14:37:51 EDT
These files are created by the %post scriptlet

rpm --scripts xmltex
Comment 2 Jamie Guinan 2002-07-19 15:19:45 EDT
Ok, then it looks like the %post scriptlet isn't working.

If I run the commands indicated by "rpm --scripts xmltex" by hand
(as root), the second one fails with,

This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C 7.3.3.1) (INITEX)
(Fatal format file error; I'm stymied)
fmtutil: `pdftex -ini -fmt=pdfxmltex -progname=pdfxmltex &pdflatex
pdfxmltex.ini' failed.

and the missing files are still not created.

I don't understand the workings of tetex well enough to
know what/where the source of the problem is.
Comment 3 Tim Waugh 2002-07-22 16:50:18 EDT
Was this an upgrade?  There was an anaconda bug that caused many packages not 
to be upgraded.  You might need to upgrade tetex* by hand.
Comment 4 Jamie Guinan 2002-07-23 01:43:01 EDT
Yes it was an upgrade from 7.2, and indeed some of the RPMs were
not updated.  Updating them fixed my problems.  Thank you!

Note You need to log in before you can comment on or make changes to this bug.