Bug 692781 - Broadcom drivers missing from dracut-network
Broadcom drivers missing from dracut-network
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dracut (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Harald Hoyer
Release Test Team
:
Depends On:
Blocks: 442980
  Show dependency treegraph
 
Reported: 2011-04-01 02:37 EDT by Ales Kozumplik
Modified: 2014-09-30 19:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: dracut-004-47
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 07:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2011-04-01 02:37:33 EDT
see https://bugzilla.redhat.com/show_bug.cgi?id=442980#c44.

A person testing bnx partial offload iscsi complains the drivers are missing from dracut. I checked and the following drivers:

bnx2
bnx2x
bnx2i

are indeed not mentioned in the 'installkernel' dracut-network's iscsi module.

Could those be added?
Comment 2 Harald Hoyer 2011-04-01 03:52:14 EDT
(In reply to comment #0)
> see https://bugzilla.redhat.com/show_bug.cgi?id=442980#c44.
> 
> A person testing bnx partial offload iscsi complains the drivers are missing
> from dracut. I checked and the following drivers:
> 
> bnx2
> bnx2x
> bnx2i
> 
> are indeed not mentioned in the 'installkernel' dracut-network's iscsi module.
> 
> Could those be added?

workaround:

# echo "add_drivers+=" bnx2 bnx2x bnx2i "  >> /etc/dracut.conf.d/bnx.conf
# dracut -f
Comment 3 Harald Hoyer 2011-04-01 03:52:51 EDT
(In reply to comment #2)
> workaround:
> 
> # echo "add_drivers+=" bnx2 bnx2x bnx2i "  >> /etc/dracut.conf.d/bnx.conf
> # dracut -f

# echo 'add_drivers+=" bnx2 bnx2x bnx2i "'  >> /etc/dracut.conf.d/bnx.conf
# dracut -f
Comment 4 RHEL Product and Program Management 2011-04-03 22:11:57 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 Ales Kozumplik 2011-04-04 02:24:31 EDT
PM,

I am proposing this as a blocker since it blocks QA on the bug 442980.
Comment 9 Alexander Todorov 2011-04-27 06:51:17 EDT
# rpm -q dracut-network
dracut-network-004-52.el6.noarch

# rpm -q dracut-network -l | xargs grep bnx2
/usr/share/dracut/modules.d/95iscsi/installkernel:instmods iscsi_tcp crc32c iscsi_ibft be2iscsi bnx2 bnx2x bnx2i


bnx2, bnx2x and bnx2i are now present.
Comment 10 errata-xmlrpc 2011-05-19 07:54:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0523.html

Note You need to log in before you can comment on or make changes to this bug.