Bug 692785 - Error in console when first access from a browser occurs after fresh installation.
Error in console when first access from a browser occurs after fresh installa...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Deployment (Show other bugs)
1.3-alpha-1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-04-01 03:02 EDT by Kenichi Takemura
Modified: 2014-08-04 18:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.5-SNAPSHOT (20120216-2319)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
JMeter test config (4.59 KB, application/octet-stream)
2012-02-15 21:25 EST, Sean Flanigan
no flags Details

  None (edit)
Description Kenichi Takemura 2011-04-01 03:02:16 EDT
Description of problem:

I installed Zanata.war in my vm and started JBOSS.

When I access to the url 'http://localhost:8080/zanata' from firefox browser, Zanata home page does not show up for a long time and there is an Stack trance in JBOSS console.


06:49:02,008 ERROR [[/zanata]] セッションイベントリスナが例外を投げました
org.jboss.seam.InstantiationException: Could not instantiate Seam component: org.jboss.seam.security.ruleBasedPermissionResolver
	at org.jboss.seam.Component.newInstance(Component.java:2144)
	at org.jboss.seam.contexts.Contexts.startup(Contexts.java:304)
	at org.jboss.seam.contexts.Contexts.startup(Contexts.java:278)
	at org.jboss.seam.contexts.Lifecycle.beginSession(Lifecycle.java:233)
	at org.jboss.seam.contexts.ServletLifecycle.beginSession(ServletLifecycle.java:155)
	at org.jboss.seam.servlet.SeamListener.sessionCreated(SeamListener.java:46)
	at org.apache.catalina.session.StandardSession.tellNew(StandardSession.java:397)
	at org.apache.catalina.session.StandardSession.setId(StandardSession.java:369)
	at org.apache.catalina.session.ManagerBase.createSession(ManagerBase.java:829)
	at org.apache.catalina.session.StandardManager.createSession(StandardManager.java:291)
	at org.apache.catalina.connector.Request.doGetSession(Request.java:2367)
	at org.apache.catalina.connector.Request.getSession(Request.java:2094)
	at org.apache.catalina.connector.RequestFacade.getSession(RequestFacade.java:833)
	at javax.servlet.http.HttpServletRequestWrapper.getSession(HttpServletRequestWrapper.java:216)
	at org.apache.catalina.core.ApplicationHttpRequest.getSession(ApplicationHttpRequest.java:544)
	at com.sun.faces.context.SessionMap.getSession(ExternalContextImpl.java:1006)
	at com.sun.faces.context.SessionMap.put(ExternalContextImpl.java:969)
	at org.jboss.seam.contexts.BasicContext.set(BasicContext.java:84)
	at org.jboss.seam.Component.newInstance(Component.java:2126)
	at org.jboss.seam.Component.getInstance(Component.java:2021)
	at org.jboss.seam.Component.getInstance(Component.java:2000)
	at org.jboss.seam.Component.getInstance(Component.java:1994)
	at org.jboss.seam.Component.getInstance(Component.java:1967)
	at org.jboss.seam.web.Session.getInstance(Session.java:122)
	at org.jboss.seam.contexts.FacesLifecycle.beginRequest(FacesLifecycle.java:56)
	at org.jboss.seam.jsf.SeamPhaseListener.beforeRestoreView(SeamPhaseListener.java:381)
	at org.jboss.seam.jsf.SeamPhaseListener.beforeServletPhase(SeamPhaseListener.java:140)
	at org.jboss.seam.jsf.SeamPhaseListener.beforePhase(SeamPhaseListener.java:118)
	at com.sun.faces.lifecycle.Phase.handleBeforePhase(Phase.java:214)
	at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:96)
	at com.sun.faces.lifecycle.RestoreViewPhase.doPhase(RestoreViewPhase.java:102)
	at com.sun.faces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:118)
	at javax.faces.webapp.FacesServlet.service(FacesServlet.java:265)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:638)
	at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:444)
	at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:382)
	at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:310)
	at org.tuckey.web.filters.urlrewrite.NormalRewrittenUrl.doRewrite(NormalRewrittenUrl.java:195)
	at org.tuckey.web.filters.urlrewrite.RuleChain.handleRewrite(RuleChain.java:159)
	at org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:141)
	at org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:90)
	at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:406)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:83)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:73)
	at org.jboss.seam.web.ExceptionFilter.doFilter(ExceptionFilter.java:64)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:178)
	at org.ajax4jsf.webapp.BaseFilter.handleRequest(BaseFilter.java:290)
	at org.ajax4jsf.webapp.BaseFilter.processUploadsAndHandleRequest(BaseFilter.java:368)
	at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:495)
	at org.jboss.seam.web.Ajax4jsfFilter.doFilter(Ajax4jsfFilter.java:56)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:60)
	at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
	at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:433)
	at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
	at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	at java.lang.Thread.run(Thread.java:636)
Caused by: java.lang.IllegalArgumentException: could not set property value: org.jboss.seam.security.ruleBasedPermissionResolver.setSecurityRules
	at org.jboss.seam.Component.setPropertyValue(Component.java:1915)
	at org.jboss.seam.Component.initialize(Component.java:1528)
	at org.jboss.seam.Component.postConstructJavaBean(Component.java:1453)
	at org.jboss.seam.Component.postConstruct(Component.java:1376)
	at org.jboss.seam.Component.newInstance(Component.java:2129)
	... 79 more
Caused by: java.lang.IllegalArgumentException: Could not invoke method by reflection: RuleBasedPermissionResolver.setSecurityRules(org.drools.RuleBase) with parameters: (org.jboss.seam.drools.RuleBase) on: org.jboss.seam.security.permission.RuleBasedPermissionResolver
	at org.jboss.seam.util.Reflections.invoke(Reflections.java:32)
	at org.jboss.seam.Component.setPropertyValue(Component.java:1911)
	... 83 more
Caused by: java.lang.IllegalArgumentException: argument type mismatch
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.jboss.seam.util.Reflections.invoke(Reflections.java:22)
	... 84 more


Version-Release number of selected component (if applicable):
http://hudson.englab.bne.redhat.com/hudson/view/Tag%20Build/job/flies-tag-build-war/12/net.openl10n.flies$flies-war/artifact/net.openl10n.flies/flies-war/1.3-alpha-1/zanata.war

java-1.6.0-openjdk-1.6.0.0-1.31.b17.el6_0.x86_64

How reproducible:
1/1

Steps to Reproduce:
1. https://tcms.engineering.redhat.com/case/86687/?from_plan=3720
2.
3.
  
Actual results:
Zanata home page does not show up for a long time and there is an Stack trance in JBOSS console.

Expected results:
Zanata installation completes.

Additional info:
Comment 1 Kenichi Takemura 2011-04-01 03:03:42 EDT
Oh when I quit JOBSS by Ctrl-C, firefox displayed Zanata home page.
Comment 2 Sean Flanigan 2011-09-07 00:33:36 EDT
Assigning to Scrum product owner for prioritisation.
Comment 3 Sean Flanigan 2012-01-30 23:13:39 EST
Reproducible with JMeter (10 threads GETting /zanata) using a 1.5-SNAPSHOT build.

Seems to be caused by JBSEAM-3999.  Workaround implemented in https://github.com/zanata/zanata/commit/db7678fdc9f2b69380b020c6e9615d83a6861391 (master branch)
Comment 4 Sean Flanigan 2012-02-15 21:25:57 EST
Created attachment 562373 [details]
JMeter test config
Comment 5 Ding-Yi Chen 2012-02-16 20:53:12 EST
VERIFIED with Zanata version 1.5-SNAPSHOT (20120216-2319)

Note You need to log in before you can comment on or make changes to this bug.