Bug 69280 - gnomeicu can cause total system freeze, seemingly when messages cross paths
gnomeicu can cause total system freeze, seemingly when messages cross paths
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-19 16:54 EDT by Fred T. Hamster
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 11:33:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred T. Hamster 2002-07-19 16:54:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc2)
Gecko/20020510

Description of problem:
Running gnomeicu and connected to the icq network.  I have a friend on and we
send messages back and forth.  Fairly often, I will hit enter to send a message
and that's the last my machine is heard from.  Mouse stops moving,
ctrl-alt-backspace no longer exits X windows, can't jump to other console
windows, ctrl-alt-del does nothing, machine seems to become a brick.  My theory
currently is that a send from me and a send from my friend cross paths and
gnomeicu freaks out and performs some operation that entirely brings down Linux.
 Has happened both on athlon architecture and on p3 (i686).  This seemed to
happen with the original version of GnomeICU so I went and got the latest
(0.98.2).  It definitely happens with that, pretty repeatably.  I am submitting
it as a RedHat bug because it takes down the entire operating system, which a
simple error in an app should not be able to do.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. run gnomeicu
2. login to icq network with valid user id.
3. start chatting with a friend.
4. send messages back and forth with friend (friend should send simultaneously
also) as fast as possible.
5. usually that will shortly lead to this crash.
	

Actual Results:  machine totally freezes up.  no key combos have effect, mouse
does not move.  hard reset is only way to wake machine up again.  happens on two
different machines (two different architectures also--athlon and P3), both with
redhat 7.2, kernel 2.4.9-34.  happened on earlier versions of 2.4 kernel also. 
both machines are reasonably current 1 ghz boxes with nvidia graphics cards (one
has riva tnt 2, other geforce 3 ultra pro).  both have sound blaster live sound
card, but this behavior doesn't happen with other apps that use the sound card
(like yahoo messenger or gaim).

Expected Results:  messages should be received on both sides with no freeze,
regardless of rate or timing of the sends.

Additional info:

i've seen nothing appear in any logs after this freeze occurs.
i've repeatedly run up2date to ensure that both machines have the latest.  this
hasn't helped yet.
keep in mind that i am using gnomeicu 0.98.2, but i think it happened with the
shipped version of gnomeicu also.  regardless, if any user mode app can take
down the whole system, that's an item of grave concern.
Comment 1 Havoc Pennington 2002-07-21 22:12:11 EDT
Has to be a kernel issue if a non-root app can lock the system.
Comment 2 Arjan van de Ven 2002-07-22 11:21:52 EDT
you're not running the nvidia binary only kernel drivers are you ?
Comment 3 Fred T. Hamster 2002-07-22 11:24:55 EDT
i'm running the nvidia drivers which i've compiled specifically for the current
kernel.  i don't use their prepackaged binaries.
Comment 4 Fred T. Hamster 2003-01-12 11:33:46 EST
it turns out this was a symptom of the sound driver being messed up.  there was
no cure besides installing a newer kernel.  i believe the defective sound
support was in 2.4.9-34, an errata kernel.  other IM apps were behaving the same
way.  sorry i didn't figure this out sooner and also that i lost track of the
bug report for a bit.

Note You need to log in before you can comment on or make changes to this bug.