Bug 69284 - ncurses library missing for make menuconfig
Summary: ncurses library missing for make menuconfig
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-19 21:55 UTC by Carl T. Miller
Modified: 2015-01-07 23:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 21:23:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl T. Miller 2002-07-19 21:55:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I've installed all four rpms that have "ncurses" in the name, yet I still get an
error message when I run make "menuconfig".  The exact message is:  /usr/bin/ld:
 cannot find -lncurses


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.su -
2.cd /usr/src/linux*
3.make menuconfig
	

Actual Results:  Get error message about missing ncurses library.

Expected Results:  I expected "make menuconfig" to work.

Additional info:

I installed four different rpms from the 7.3 distro which have "ncurses"
anywhere in the filename. What am I missing?  And why isn't this library
automatically installed?  It's used in many programs.

Comment 1 Eido Inoue 2003-08-01 21:23:08 UTC
There are only two ncurses packages-- the main package and the -devel
subpackage. I'm unable to reproduce your problem with a stock 7.3 install.


Note You need to log in before you can comment on or make changes to this bug.