Bug 69288 - Nautilus is inconsistent in what View settings are remembered
Summary: Nautilus is inconsistent in what View settings are remembered
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-20 01:36 UTC by Charles R. Anderson
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-16 14:51:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Charles R. Anderson 2002-07-20 01:36:43 UTC
Description of Problem:

If you open Nautilus, Hide the Sidebar, close the window, then
reopen it, the Sidebar reappears.  The same applies for the Toolbar, Location
Bar, and Status Bar.  Nautilus DOES remember other View preferences
automatically, such as the Zoom level, View as Icons/List, and Arrange Items
selections.

For consistency, it should EITHER remember the preferences to Show/Hide the
sidebars, OR not remember the other preferences.  I realize the preferences are
configurable through Edit->Preferences, but perhaps Edit->Preferences should
have a "Remember each folder's settings automatically" option which controls
this behavior for EVERY setting.

Version-Release number of selected component (if applicable): 2.0.0-6


How Reproducible:  Always


Steps to Reproduce:
1. Double click on a folder
2. Select View->Hide Sidebar
3. Close the window
4. Double click on the same folder

Actual Results:

The sidebar is shown.

Expected Results:

The sidebar preference should be remembered (or no settings should be
remembered, or this behavior should be configurable).

Additional Information:

Comment 1 Havoc Pennington 2002-07-22 12:19:37 UTC
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=88783

Comment 2 Alexander Larsson 2003-01-16 14:51:59 UTC
Whether the sidebar is visible or not is not part of the directory metadata, so
it's not stored with the current view and zoom level. However, the closed/opened
sidebar for a new window state is now stored from the latest window you closed.

I don't consider this inconsistant, since the sidebar is part of the navigation
interface and not the directory view.


Note You need to log in before you can comment on or make changes to this bug.