Bug 692968 - NFS Permission Denied Errors [NEEDINFO]
NFS Permission Denied Errors
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.5
All All
medium Severity low
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On: 264661
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-01 16:18 EDT by Matthew Miller
Modified: 2014-02-05 16:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 264661
Environment:
Last Closed: 2014-02-05 16:47:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mattdm: needinfo? (lars)


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2011-04-01 16:18:04 EDT
+++ This bug was initially created as a clone of Bug #264661 +++


--- Additional comment from lars@oddbit.com on 2011-04-01 16:13:45 EDT ---

We've just run into this problem on two of our RHEL5.5 systems.  That is, systems that had previously been exporting NFS filesystems without a problem suddenly started reporting "permission denied" despite entries like this in /etc/exports:

  /mnt/somefilesystem *(ro)

The solution was to manually mount /proc/fs/nfsd.  

/etc/modprobe.d/modprobe.conf.dist is unmodified from the stock configuration and includes the necessary install/remove rules:

  install nfsd /sbin/modprobe --first-time --ignore-install nfsd && { /bin/mount -t nfsd nfsd /proc/fs/nfsd > /dev/null 2>&1 || :; }
  remove nfsd { /bin/umount /proc/fs/nfsd > /dev/null 2>&1 || :; } ; /sbin/modprobe -r --first-time --ignore-remove nfsd

This happened on unrelated systems, maintained by two distinct groups of people.

Since the mount operation is idempotent (if the filesystem is already mounted, running "mount -t nfsd nfsd /proc/fs/nfsd" simply reports an error), we've simply made this part of the NFS startup script.  It seems that this might be a good idea in general.
Comment 1 Steve Dickson 2011-09-30 16:53:01 EDT
Could this possibly be a Selinux issue? Does setenfore 0 make the problem go away?
Comment 2 Matthew Miller 2011-09-30 20:53:00 EDT
Pretty sure that SELinux was off on the systems. Lars, do you remember which machines these were?
Comment 6 RHEL Product and Program Management 2014-01-29 05:38:07 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 7 RHEL Product and Program Management 2014-02-05 16:47:27 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.