Bug 69301 - RFE: Add Windows NTFS to boot loader autoconfig
RFE: Add Windows NTFS to boot loader autoconfig
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-20 05:40 EDT by Warren Togami
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-05 07:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-07-20 05:40:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020717

Description of problem:
Today at an InstallFest at the University of Hawaii I was helping a few students
prepare their Windows XP systems for dual-boot operation in preperation for
their ICS412 operating system class this Fall (homework hacking the Linux
kernel!).  I noticed that Red Hat 7.3 does not autodetect the presence of NTFS
Windows partitions and create a boot loader entry, and someone else mentioned on
limbo-list that Limbo does not either.

Please make Anaconda automatically create the GRUB or LILO entry to chainload
Windows 2000/XP on an NTFS partition.  It currently adds an entry for FAT32
Windows partitions, but not NTFS.
Comment 1 Mike Chambers 2002-07-20 09:17:08 EDT
I got this to work by clicking the "add" button (I think) and it found and 
added my XP NTFS partition to grub with no problem.  But it didn't add it 
automatically until I did that.  So not sure what the problem is.
Comment 2 Jeremy Katz 2002-07-23 00:30:52 EDT
Bootable partitions don't really have any easily distinguishable feature.  I've
changed the heuristic we used from find the first FAT partition to find the
first FAT or NTFS partition now that NTFS is more common.
Comment 3 Warren Togami 2002-08-05 07:13:16 EDT
Thanks, this appears to be working in Limbo2 now.

Can the default label be changed from "DOS" to something like "Windows FAT32" or
"Windows NTFS" since the vast majority of users will be using Windows rather
than DOS?  Just a minor cosmetic issue.
Comment 4 Mike McLean 2002-08-09 16:35:14 EDT
CLOSED->RAWHIDE (based on reporter's confirmation)

Note You need to log in before you can comment on or make changes to this bug.