Bug 69307 - Can't install source rpms as non-root user
Can't install source rpms as non-root user
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-20 13:19 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-20 13:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-07-20 13:19:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020713

Description of problem:
Even with .rpmmarcos to redefine the locations you can't install a source rpm
because rpm wants to write to the database.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login as non-root user
2. rpm -i package.src.rpm

	

Actual Results:  Error trying to open database

Expected Results:  For it to come back to the command line and to have installed
the files in the directories that .rpmmarcos specifies.

Additional info:
Comment 1 Jeff Johnson 2002-07-20 13:50:51 EDT
If this is rpm-4.1, then the problem is fixed in RawHide.

Otherwise, please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.