Bug 693116 - RFE: Use XDG base dir spec instead of home
RFE: Use XDG base dir spec instead of home
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-02 15:00 EDT by jmccann
Modified: 2015-01-14 18:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-16 04:36:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmccann 2011-04-02 15:00:10 EDT
Currently Eclipse uses ~/.eclipse for configuration and data files.  It would be great if we could change it to follow the XDG Base Directory Spec http://standards.freedesktop.org/basedir-spec/basedir-spec-latest.html.

There are a number of advantages to this including making it much easier to migrate data across systems or during upgrades.
Comment 1 Alexander Kurtakov 2011-04-04 06:37:20 EDT
Eclipse doesn't make a clean difference between config, cache, data and runtime data. Wherever we choose to put this data it should be in a single directory because the layout of ~/.eclipse folder is the same on all platforms and not all of them expose xdg variables. As most of the data in ~/.eclipse is installation specific we would need to put it in $XDG_DATA_HOME, am I right? 
Additionally Eclipse doesn't support reusing metadata from previous version and if it's put data_home we will not gain anything. 
I'm all for following XDG Directory Spec but this requires working with upstream to get it fixed and I won't be able to work on that anytime soon. Help is more than welcome!
Comment 2 Andrew Overholt 2011-04-27 08:13:55 EDT
We should file this upstream (I'm guessing Equinox but it'll involve lots of teams):

  https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Equinox&component=Framework
Comment 3 Alexander Kurtakov 2014-01-16 04:36:03 EST
Closing as this would not be accepted upstream and there is even noone that would spend the huge amount of work on that.

Note You need to log in before you can comment on or make changes to this bug.