Bug 693126 - (openvas-admin) Review Request: openvas-administrator - Administrator Module for the Open Vulnerability Assessment System (OpenVAS)
Review Request: openvas-administrator - Administrator Module for the Open Vul...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-SECLAB
  Show dependency treegraph
 
Reported: 2011-04-02 16:44 EDT by Michal Ambroz
Modified: 2014-05-26 14:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-26 14:42:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2011-04-02 16:44:38 EDT
Hello,
Please I would like to ask you for review of a new openvas-administrator package.

Spec URL: http://rebus.fedorapeople.org/SPECS/openvas-administrator.spec
SRPM URL: http://rebus.fedorapeople.org/SRPMS/openvas-administrator-1.1.1-1.fc14.src.rpm

Description:
The OpenVAS Administrator acts as a command line tool or as a full service
daemon offering the OpenVAS Administration Protocol (OAP). The most important
tasks are the user management and feed management. GSA support OAP and users
with the role "Admin" can access the OAP functionality.

Best regards
Michal Ambroz
Comment 1 Michal Ambroz 2011-04-02 16:58:55 EDT
koji build dist-f16 --scratch /home/mambroz/rpmbuild/SRPMS/openvas-administrator-1.1.1-1.fc14.src.rpm 
Uploading srpm: /home/mambroz/rpmbuild/SRPMS/openvas-administrator-1.1.1-1.fc14.src.rpm
[====================================] 100% 00:00:04 137.46 KiB  33.44 KiB/sec
Created task: 2969158
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=2969158
Watching tasks (this may be safely interrupted)...
2969158 build (dist-f16, openvas-administrator-1.1.1-1.fc14.src.rpm): open (x86-17.phx2.fedoraproject.org)
  2969160 buildArch (openvas-administrator-1.1.1-1.fc14.src.rpm, i686): open (x86-20.phx2.fedoraproject.org)
  2969159 buildArch (openvas-administrator-1.1.1-1.fc14.src.rpm, x86_64): open (x86-02.phx2.fedoraproject.org)
  2969160 buildArch (openvas-administrator-1.1.1-1.fc14.src.rpm, i686): open (x86-20.phx2.fedoraproject.org) -> closed
  0 free  2 open  1 done  0 failed
2969158 build (dist-f16, openvas-administrator-1.1.1-1.fc14.src.rpm): open (x86-17.phx2.fedoraproject.org) -> closed
  0 free  1 open  2 done  0 failed
  2969159 buildArch (openvas-administrator-1.1.1-1.fc14.src.rpm, x86_64): open (x86-02.phx2.fedoraproject.org) -> closed
  0 free  0 open  3 done  0 failed

2969158 build (dist-f16, openvas-administrator-1.1.1-1.fc14.src.rpm) completed successfully
Comment 2 Siem Korteweg 2011-07-14 16:18:01 EDT
Some remarks, as this is not a formal review.

- the source rpm is for FC14, not FC15

- rpmbuild failed:
  extend the Buildrequires with gcc and xmltoman

- you do not need a %clean script:
  refer to http://fedoraproject.org/wiki/Packaging:Guidelines#.25clean

- systemd is required for init-scripts for Fedora 15+:
  refer to http://fedoraproject.org/wiki/Packaging:SysVInitScript#Initscripts_in_addition_to_systemd_unit_files
  this also affects the current Requires

- sqlite-devel is not required for building
  after removing this rpm and removing its Buildrequires from the spec file, the rpmbuild succeeded and all files in the new rpm have the same size as before

- why do you require file /usr/bin/xsltproc and not the rpm libxslt it is contained in?
Comment 3 Michal Ambroz 2012-01-24 04:17:10 EST
Hi Siem,
thank you for your remarks. Sorry for delay.
The core openvas-libraries, openvas-scanner, openvas-manager finally got to some usable state so I can follow-up on the rest of the packages.

SPEC: http://rebus.fedorapeople.org/SPECS/openvas-administrator.spec
SRPM:
http://rebus.fedorapeople.org/SRPMS/openvas-administrator-1.1.2-1.fc16.src.rpm


(In reply to comment #2)
> - rpmbuild failed:
>   extend the Buildrequires with gcc and xmltoman
Added buildrequires on xmltoman. Dependency to gcc is not needed.
Here are logs from koji scratch build for F17
http://koji.fedoraproject.org/koji/taskinfo?taskID=3728246

 
> - you do not need a %clean script:
I actually plan this package for EPEL as well and clean is needed there.

> - systemd is required for init-scripts for Fedora 15+:
Yes you are right. 
I have got reason for that - rest of the suite (openvas-scanner, openvas-manager) is still using systemv. As I target for EPEL I would preffer to finish the whole suite first with systemV style init scripts to have it prepared and tested for EPEL. Then I would like to move all to systemd.

> - sqlite-devel is not required for building
removed. It was copy paste from other openvas package.
 
> - why do you require file /usr/bin/xsltproc and not the rpm libxslt it is
> contained in?
The rpmlint complained with error about the explicit dependency on libxslt while it is gracefull about having explicit dependency on file. From this I believed it is preferred way. 
I have changed it to require libxslt.


Best regards
Michal Ambroz
Comment 4 Michal Ambroz 2012-04-09 22:40:10 EDT
SPEC: http://rebus.fedorapeople.org/SPECS/openvas-administrator.spec
SRPM:
http://rebus.fedorapeople.org/SRPMS/openvas-administrator-1.1.2-2.fc17.src.rpm

Updated from sysv init scripts to systemd init scripts.

Scratch build for rawhide - http://koji.fedoraproject.org/koji/taskinfo?taskID=3975807
Scratch build for f17 - http://koji.fedoraproject.org/koji/taskinfo?taskID=3975814


Best regards
Michal Ambroz
Comment 5 Michal Ambroz 2012-11-16 00:52:50 EST
OpenVas5 seems to work with current version of gnutls in Fedora 17.

SPEC: http://rebus.fedorapeople.org/SPECS/openvas-administrator.spec
SRPM: http://rebus.fedorapeople.org/SRPMS/openvas-administrator-1.2.1-1.fc17.src.rpm

The openvas-administrator seems to work now with the OpenVas5 packages and current version of gnutls on Fedora17. 
You need to use srpms from rawhide in order to try on Fedroa 17:
openvas-libraries https://koji.fedoraproject.org/koji/buildinfo?buildID=366563
openvas-scanner https://koji.fedoraproject.org/koji/buildinfo?buildID=366564
openvas-manager https://koji.fedoraproject.org/koji/buildinfo?buildID=366590

Best regards
Michal Ambroz
Comment 6 Michal Ambroz 2013-03-16 19:24:24 EDT
Update to OpenVas6.

SPEC: http://rebus.fedorapeople.org/SPECS/openvas-administrator.spec
SRPM: http://rebus.fedorapeople.org/SRPMS/openvas-administrator-1.3-1.beta1.fc18.src.rpm

Other Openvas6 packages (libraties,scanner,manager) are already in rawhide.

Best regards
Michal Ambroz
Comment 7 Fabian Affolter 2014-05-26 14:42:24 EDT
openvas-administrator was merged into openvas-manager.

Note You need to log in before you can comment on or make changes to this bug.