Bug 693152 - XFCE does not provide authentication dialog for Firewall, PackageKit GUIs
XFCE does not provide authentication dialog for Firewall, PackageKit GUIs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-04-03 01:56 EDT by Jonathan Rushdoony
Modified: 2012-01-16 15:20 EST (History)
11 users (show)

See Also:
Fixed In Version: xfce4-session-4.8.1-4.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-21 01:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Rushdoony 2011-04-03 01:56:13 EDT
Description of problem:
When adding/removing package using GUI, no dialog appears to authenticate and no action is allowed.

Version-Release number of selected component (if applicable):
XFCE Desktop 4.8

How reproducible:
Add or remove package using GUI.  Modify Firewall using GUI.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
"Authorization Failed" message appears and cannot add/remove package, modify firewall, etc.

Expected results:


Additional info:
Comment 1 Richard Hughes 2011-04-05 04:23:30 EDT
Not a PackageKit issue, re-assigning to something more valid.
Comment 2 Kevin Fenzi 2011-04-05 18:47:20 EDT
How did you install Xfce ?

what does: 'rpm -qa | grep polkit' output?
Comment 3 Jonathan Rushdoony 2011-04-05 20:40:15 EDT
(In reply to comment #2)
> How did you install Xfce ?
> 
> what does: 'rpm -qa | grep polkit' output?

I installed XFCE using the F15 Beta candidate "Feora-15-Beta-x86_64-Live-XFCE.iso
"

Here's the output of $ rpm -qa grep polkit
polkit-0.101-4.fc15.x86_64
grep-2.7-4.fc15.x86_64

Thanks for looking into this issue.
Comment 4 Kevin Fenzi 2011-04-06 10:20:49 EDT
if you do a: 

yum install polkit-gnome

does it start working as expected?
Comment 5 Jonathan Rushdoony 2011-04-07 21:20:43 EDT
No, not working.  I have had polkit-gnome installed.
$ rpm -q polkit-gnome
polkit-gnome-0.101-1.fc15.x86_64
Comment 6 Nathan Thomas 2011-04-10 10:47:29 EDT
I can reproduce this bug using the same Feora-15-Beta-x86_64-Live-XFCE.iso (though from the live environment, not installed). Trying to modify the firewall with system-config-firewall brings up the following error:

org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.firewall.auth 

The same bug also seems to be preventing me from mounting installed partitions.

polkit-gnome and gnome-keyring are both installed, and the gnome-keyring daemon is running.

Nathan
Comment 7 rvcsaba 2011-04-11 06:25:56 EDT
I use Xfce on Fedora 15. I use system-config-firewall, I get error message:

"org.fedoraproject.slip.dbus.service.PolKit.NotAuthorizedException.org.fedoraproject.config.firewall.auth:"

If I use system-config-firewall tool on root account (su -c system-config-firewall), work it. (Sorry my very poor english. :( )
Comment 8 Kevin Fenzi 2011-04-16 12:46:03 EDT
Could folks try switching to gdm from lxdm? 

The nightlys starting tonight should have gdm instead, if you have an installed system doing a 'yum install gdm' and then moving /etc/sysconfig/desktop aside should get you gdm on boot. 

I'd like to see if this problem persists with gdm...
Comment 9 Jonathan Rushdoony 2011-04-16 13:39:42 EDT
(In reply to comment #8)
> Could folks try switching to gdm from lxdm? 
> 
> The nightlys starting tonight should have gdm instead, if you have an installed
> system doing a 'yum install gdm' and then moving /etc/sysconfig/desktop aside
> should get you gdm on boot. 
> 
> I'd like to see if this problem persists with gdm...

The problem persists with gdm.  I installed gdm and renamed /etc/sysconfig/desktop to desktop_old.  On reboot, I got gdm at login (it was the Gnome 3 login splash screen).  But the problem with packagekit and firewall remained.  Thanks for continuing to work on this problem.
Comment 10 rvcsaba 2011-04-16 13:56:20 EDT
I use gdm, too. system-config-firewall work only if I started from root terminal.
Comment 11 Christoph Wickert 2011-04-16 18:42:23 EDT
This is the result of http://lists.fedoraproject.org/pipermail/devel-announce/2011-February/000758.html, thus we need to ship a desktop file to start polkit-gnome-authentication-agent-1. Fixed package is building now.
Comment 12 Fedora Update System 2011-04-16 19:10:11 EDT
xfce4-session-4.8.1-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xfce4-session-4.8.1-4.fc15
Comment 13 rvcsaba 2011-04-16 19:17:55 EDT
xfce4-session-4.8.1-4.fc15 work correctly. Firewall GUI, virtual machine manager work.

Thank you! :)
Comment 14 Fedora Update System 2011-04-16 22:04:32 EDT
Package xfce4-session-4.8.1-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xfce4-session-4.8.1-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xfce4-session-4.8.1-4.fc15
then log in and leave karma (feedback).
Comment 15 Jonathan Rushdoony 2011-04-17 16:06:38 EDT
(In reply to comment #14)
> Package xfce4-session-4.8.1-4.fc15:
> * should fix your issue,
> * was pushed to the Fedora 15 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing xfce4-session-4.8.1-4.fc15'
> as soon as you are able to.

The authentication agent now starts when using firewall and add/remove software.  However, I get SE Linux errors when changing firewall settings, No such errors when I use "sudo system-config-firewall" from command line.  No problems with add/remove packagekit application.  Thank you.  Do I still need to use gdm?
Comment 16 Kevin Fenzi 2011-04-17 18:48:37 EDT
Please report the selinux errors in a new bug against selinux-policy. 

lxdm might well work ok now, you could try it and see. 

Thanks.
Comment 17 Jonathan Rushdoony 2011-04-18 20:20:42 EDT
(In reply to comment #16)
> Please report the selinux errors in a new bug against selinux-policy. 

Will do so.
 
> lxdm might well work ok now, you could try it and see. 

Yes, lxdm works fine.

Thanks for all of your help.
Comment 18 Fedora Update System 2011-04-21 01:30:46 EDT
xfce4-session-4.8.1-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 freetg 2011-12-04 07:30:29 EST
Fedora 16 x86_64,Xfce desktop has the same problem.
Comment 20 Christoph Wickert 2011-12-04 08:47:24 EST
It should't. How did you install Xfce? The Xfce spin does not have this problem.

Please give me the output of:

 $ ps aux | grtep polkit
 $ rpm | grep polkit
 $ cat ~/.config/autostart/xfce-polkit-gnome-authentication-agent-1.desktop

Thanks!
Comment 21 Geert Evenhuis 2012-01-16 15:20:16 EST
I have discovered that if you choose the classic gnome screen with compiz then you do not get an authentication screen and update software fails.
I run fedora 16 and prefer the classic screen.
My fix is that at login I choose the gnome 3 screen and do my software updates then log out and go to my classic screen. 
I found the equivalent file mentioned in comment 20 so it appears that if you fail to start gnome 3 and fallback to a classic screen then the authentication is started, but if you choose the classic screen then it does not.

Note You need to log in before you can comment on or make changes to this bug.