Bug 69316 - no DNS bad permissions on /etc/hosts /etc/resolv.conf
no DNS bad permissions on /etc/hosts /etc/resolv.conf
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-20 15:33 EDT by cookgb
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 09:01:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cookgb 2002-07-20 15:33:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Changing to a static IP address and choosing primary and secondary DNS using
/usr/bin/neat removes read permission for others on /etc/resolv.conf and
/etc/hosts.  This prevents DNS from working and causes problems where the IP
address of localhost cannot be looked up.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start /usr/bin/neat
2.In the Devices tab, edit the eth0 device, setting all field for a "Satically
set IP address" and clicking on "OK" and then applying the changes.
3.In the DNS tab, set primary and secondary DNS IP addresses and apply the changes.

	

Actual Results:  1.In a terminal window, type "dig".  It will not work because
read permission for general users has been removed on /etc/resolv.conf.
2.Read permission for general users on /etc/hosts has also been removed.

Expected Results:  Read permission for "others" should be set on both
/etc/resolve.conf and /etc/hosts after running /usr/bin/neat and setting a
static IP address.

Additional info:
Comment 1 Harald Hoyer 2002-07-22 09:01:38 EDT
fixed in CVS... thx
Comment 2 Trond Eivind Glomsrxd 2002-07-24 12:45:23 EDT
1.10.11 has been built
Comment 3 diego.santacruz 2002-10-04 11:43:06 EDT
This bug also appears under RedHat 8.0, which has redhat-config-network-1.1.20-1.
Could you please propagate the change to Redhat 8.0?
Each time I change something in neat is makes /etc/resolv.conf and /etc/hosts
readable to root and root group only, breaking all network connectivity.

Note You need to log in before you can comment on or make changes to this bug.