Bug 69334 - RFE: If wireless card isn't in whilst install happening, no wireless configured
RFE: If wireless card isn't in whilst install happening, no wireless configured
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-21 10:59 EDT by Telsa Gwynne
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 12:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-07-21 10:59:52 EDT
Description of Problem:


This took ages to work out.

Laptop install on a Sony Vaio with one pcmcia slot. This slot normally
contains the wireless card. For the install, it needed to have the CD in
it. (Well, the pcmcia card attached to the CD drive, if that makes more 
sense.)

Install completed. Could _not_ get wireless networking to work. Eventually
light dawned. Because the wireless card was not it, eth0 didn't get set up.

Surely a single slot which can be either wireless or CD is not uncommon.
I have spent days wondering what was going on here (and I feel stupid for
not realising sooner.) 

Eventually ran redhat-config-network and /etc/init.d/pcmica restart and
got networking back. 

Perhaps for laptop installs it should prompt with something about "Will
the wireless card go where the CD is?" or something, because I don't think
it's at all obvious what's going on when the networking stops. I was 
running over the house testing signal strength for ages.
Comment 1 Brent Fox 2002-07-21 17:17:40 EDT
One of the steps in firstboot will be to set up an internet connection if one
isn't currently active.  This will happen in the "Register with RHN screen".  If
the user decides to connect to RHN, we'll try to ping www.redhat.com.  If we
can't connect, ask the user if they would like to configure a network
connection.  If they say yes, then internet-druid (part of
redhat-config-network) gets run.  I think that this would have fixed the problem
in your case except maybe the part about /etc/init.d/pcmcia restart.  I dunno if
internet-druid can handle that on it's own.
Comment 2 Michael Fulbright 2002-07-23 12:05:02 EDT
This is definately a first-boot/neat issue. The installer is only going to
handle the hardware required to get the system installed.
Comment 3 Brent Fox 2003-02-18 17:28:23 EST
Didn't get done for GinGin.  Marking as an RFE for next time.
Comment 4 Chris Lumens 2005-09-23 12:54:11 EDT
The combination of hotplug, NetworkManager, kudzu, etc. should now be taking
care of problems with PCMCIA wireless cards.  For instance, my Netgear FA401
PCMCIA card was set up properly upon bootup under FC4.

Note You need to log in before you can comment on or make changes to this bug.