Bug 693392 - x86: mce: don't print "human readable" messages for corrected errors
Summary: x86: mce: don't print "human readable" messages for corrected errors
Keywords:
Status: CLOSED DUPLICATE of bug 688281
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Prarit Bhargava
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: GSS_6_2_PROPOSED 697582
TreeView+ depends on / blocked
 
Reported: 2011-04-04 14:37 UTC by Robert Binkhorst
Modified: 2018-11-14 13:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-09 14:24:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Robert Binkhorst 2011-04-04 14:37:55 UTC
Description of problem:

On the x86 platform when there is a corrected MCE error it prints the following messages:
Mar 29 17:52:19 server1 kernel: [Hardware Error]: No human readable MCE decoding support on this CPU type.
Mar 29 17:52:19 server1 kernel: [Hardware Error]: Run the message through 'mcelog --ascii' to decode.

It should however only print them in case of a panic as per the upstream commit:

--------
The "human readable" message is not useful for corrected
errors. There's no reason to run mcelog --ascii and the
error is logged anyways. And it's pr_emerg, which is not
needed for a corrected error.

Only print it during panic.
--------

These messages are confusing to the less experienced admin.

Version-Release number of selected component (if applicable):
RHEL-6.1 beta

How reproducible:
On a system installed with RHEL-6.1 beta with correctable MCE errors you will see these messages.

Steps to Reproduce:
1. Install a machine with RHEL-6.1 beta
2. Wait for MCE errors to be corrected
3.
  
Actual results:
The system logs superfluous messages

Expected results:
These messages should only be printed in case of a panic.

Additional info:
Upstream commit that resolves this:
http://git.kernel.org/?p=linux/kernel/git/ak/linux-mce-2.6.git;a=commitdiff;h=6e3c7411d2b86bff210c59caa432e8e862037bfd

Comment 2 RHEL Program Management 2011-04-09 14:19:31 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 3 Prarit Bhargava 2011-04-09 14:24:11 UTC

*** This bug has been marked as a duplicate of bug 688281 ***


Note You need to log in before you can comment on or make changes to this bug.