Bug 69351 - tcsh uncorrectly displaying ISO8859-2 characters
tcsh uncorrectly displaying ISO8859-2 characters
Status: CLOSED DUPLICATE of bug 41991
Product: Red Hat Linux
Classification: Retired
Component: tcsh (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 04:05 EDT by Need Real Name
Modified: 2007-04-18 12:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-07-22 04:05:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When I try write some czech characters (ISO8859-2; list of problems characters
in TeX syntax: \v e, \v s, \v z, \'a, \'\i, \'e), there some strange things
happened.


How reproducible:
Always

Steps to Reproduce:
1. Open some terminal with tcsh
2. If you have czech keyboard :-( (installed with RH7.3), press some key with
ISO8859-2 character, e.g. key "2" which means "\v e" character.
3. See result and then press same key second time.
	

Actual Results:  After first pressing appeared space.
After second pressing appeared two "\v e" characters.
So it is impossible to write one "\v e" character (and other characters
described before). This means that, we cannot write almost none czech characters
in tcsh and this is terrible! :-(

Additional info:

I try different terminals gnome-term, xterm, but it always happened. Under bash
is all corect. One my colleague said, that tcsh uncorrectly means, that
ISO8859-2 is doublebyte coding system, and it isn't.

There is some info, it may be helpfull:

$locale
LANG=cs_CZ
LC_CTYPE="cs_CZ"
LC_NUMERIC="cs_CZ"
LC_TIME="cs_CZ"
LC_COLLATE="cs_CZ"
LC_MONETARY="cs_CZ"
LC_MESSAGES="cs_CZ"
LC_PAPER="cs_CZ"
LC_NAME="cs_CZ"
LC_ADDRESS="cs_CZ"
LC_TELEPHONE="cs_CZ"
LC_MEASUREMENT="cs_CZ"
LC_IDENTIFICATION="cs_CZ"
LC_ALL=

$ rpm -qi tcsh
Name        : tcsh                         Relocations: (not relocateable)
Version     : 6.10                              Vendor: Red Hat, Inc.
Release     : 6                             Build Date: Po 25. herven 2001,
05:45:29 CEST
Install date: Ht  9. kvlten 2002, 16:42:51 CEST      Build Host:
porky.devel.redhat.com
< cut >
Comment 1 Kolar, Petr 2002-08-19 14:53:20 EDT
Quick fix:

unset dspmbyte

(e.g. in your .cshrc of .tcshrc).

It seems there is a bug in tcsh-6.10.00-dspmbyte.patch (reversed condition
or something similar, but I think that !strncasecmp did not work for me).
Comment 2 Tobias Ringstrom 2002-09-13 11:58:59 EDT
This bug is a duplicate of 57302
Comment 3 Tobias Ringstrom 2002-09-13 12:33:36 EDT
...which in turn is a duplicate of bug 41991
Comment 4 Miloslav Trmač 2004-08-17 09:45:59 EDT

*** This bug has been marked as a duplicate of 41991 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:49:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.