Bug 69353 - nasm fails when compiling lame
nasm fails when compiling lame
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nasm (Show other bugs)
7.3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 05:01 EDT by Florin Andrei
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 05:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2002-07-22 05:01:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

Description of problem:
I'm compiling Lame-3.92 using the --enable-nasm option.
I got this error:

##########################################
/usr/bin/nasm -f elf -i ../../libmp3lame/i386/ scalar.nas -o scalar.lo
-l scalar.lo.lst
scalar.nas:15: error: parser: instruction expected
scalar.nas:16: error: parser: instruction expected
scalar.nas:36: error: parser: instruction expected
scalar.nas:37: error: parser: instruction expected
scalar.nas:69: error: parser: instruction expected
scalar.nas:70: error: parser: instruction expected
scalar.nas:114: error: parser: instruction expected
scalar.nas:115: error: parser: instruction expected
scalar.nas:171: error: parser: instruction expected
scalar.nas:172: error: parser: instruction expected
scalar.nas:240: error: parser: instruction expected
scalar.nas:241: error: parser: instruction expected
scalar.nas:321: error: parser: instruction expected
scalar.nas:322: error: parser: instruction expected
scalar.nas:431: error: parser: instruction expected
scalar.nas:432: error: parser: instruction expected
scalar.nas:433: error: parser: instruction expected
...and so on (the list is very long)
##########################################

It seems like a bug in nasm.
It was reported that a newer nasm (0.98.33) works fine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.compile lame-3.92 using --enable-nasm
2.
3.
	

Actual Results:  i got the above error

Expected Results:  lame should compile fine

Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-07-23 12:23:10 EDT
0.98.32 is already in rawhide, 0.98.34 should show up shortly.

Note You need to log in before you can comment on or make changes to this bug.