Bug 69355 - No netmask is passed to ipppd
No netmask is passed to ipppd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
Milan BLOCKER
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-22 05:44 EDT by Florian Schirmer
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-22 11:25:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Schirmer 2002-07-22 05:44:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
ifup-ippp does not pass the netmask (if set) to ipppd. This results in an 
incorrect netmask if the device is connected (or was connected before).

This is a bug in initscripts (because ifup-ippp is located there), but i did 
file this bug here, because the maintainer of ifup-ippp is probably the same as 
for isdn4k-util. If not please reassign.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. <Set netmask>
2. <Connect>
3. route
	

Actual Results:  Netmask is not as defined in the ifcfg-ippp? file

Expected Results:  Netmask as defined in the ifcfg-ippp? file

Additional info:

Following patch fixes the problem:

--- ifup-ippp-old       Mon Jul 22 11:41:34 2002
+++ ifup-ippp   Fri Jul 19 10:02:14 2002
@@ -322,7 +322,7 @@
     if [ "$ENCAP" = "syncppp" ]; then
         # start ipppd daemon
         logger -p daemon.info -t ifup-ippp "ipppd $options"
-        ipppd $options >/dev/null 2>&1
+        ipppd $options $netmask >/dev/null 2>&1

         # start ibod daemon
         [ "$BUNDLING" = "yes" -o "$BUNDLING" = "on" ] && [ -
n "$SLAVE_DEVICE" ] && start_ibod $DEVICE
Comment 1 Ngo Than 2002-07-25 17:47:04 EDT
you have right. It's a bug here. It's fixed in initscript-6.89-1

Note You need to log in before you can comment on or make changes to this bug.