Bug 69359 - SysVinit-2.84-4: "telinit s" doesn't stop services
SysVinit-2.84-4: "telinit s" doesn't stop services
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: SysVinit (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 08:38 EDT by Jonathan Kamens
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 01:06:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-07-22 08:38:57 EDT
This morning I ran "telinit s" (or perhaps "telinit S", I'm not sure which,
although I'm pretty sure it wasn't "telinit 1") to go to single-user mode.  Init
didn't run any of the stop scripts it should have run when switching from
runlevel 5 to runlevel 1.
Comment 1 Bill Nottingham 2002-07-22 11:19:10 EDT
The stop scripts are only run when you switch to runlevel 1; running 'telinit S'
doesn't actually switch runlevels.

Did this work before?
Comment 2 Jonathan Kamens 2002-07-22 11:24:59 EDT
"telinit s" is supposed to switch runlevels.  The man page claims that "telinit
S or "telinit s" should "tell init to switch to single user mode," which sure
sounds to me like it's supposed to switch runlevels, since I thought that the
definition of "single user mode" was "runlevel 1".

Yes, I'm pretty certain taht it worked before.

If it doesn't work properly, it should be disabled completely, i.e., "telinit s"
or "telinit S" should generate an error.
Comment 3 Bill Nottingham 2005-01-28 01:06:41 EST
Closing out unresolved bugs on older, end-of-lifed releases.
Apologies for any lack of response.

At this point I don't think we're going to change the upstream/current
behavior.

Note You need to log in before you can comment on or make changes to this bug.