Bug 693596 - OProfile package does not build with Xen support
Summary: OProfile package does not build with Xen support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: oprofile
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: William Cohen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-05 02:13 UTC by W. Michael Petullo
Modified: 2011-05-03 04:50 UTC (History)
1 user (show)

Fixed In Version: oprofile-0.9.6-20.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-02 22:27:01 UTC
Type: ---


Attachments (Terms of Use)
Patch to add Xen support to OProfile (21.98 KB, application/octet-stream)
2011-04-05 02:13 UTC, W. Michael Petullo
no flags Details

Description W. Michael Petullo 2011-04-05 02:13:12 UTC
Created attachment 489900 [details]
Patch to add Xen support to OProfile

Description of problem:
The Fedora 14 OProfile package does not provide full support for Xen.

Version-Release number of selected component (if applicable):
oprofile-0.9.6-10.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
Run "opcontrol --help"
  
Actual results:
Does not list "--passive-domains" option

Expected results:
OProfile supports passive Xen domain profiling.

Additional info:
See also:

http://www.xen.org/files/summit_3/xenoprof_tutorial.pdf
http://xenoprof.sourceforge.net/

Comment 1 William Cohen 2011-04-05 19:50:51 UTC
The oprofile patch for xen was turned off when fedora rebased to oprofile-0.9.5 because the patches did not apply cleanly:

http://pkgs.fedoraproject.org/gitweb/?p=oprofile.git;a=commit;h=c1c334d9e6052d1c8ae8ab0358bc9558eef1b75e

The website, http://xenoprof.sourceforge.net/#download, has a newer oprofile-0.9.5-xen.patch and it apply more cleanly to the oprofile-0.9.3-xen.patch.

I put a scratch build through for F14 to try and see if provides the desired xeoprof support.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2976532

Could you give one of the RPMs there a try test to see whether it works?

Comment 2 W. Michael Petullo 2011-04-06 16:22:38 UTC
The short answer is that the package proposed in comment #1 works -- I was able to use it to passively profile a DomU domain.

The long answer is that modifications to the Fedora Linux kernel are also necessary, beyond using Michael Young's 2.6.32.X-series kernel [1]. In addition to Michael's changes (adding Dom0 support), I had to apply Anil Madhavapeddy's "passive profiling on PV Ops kernel" patch [2] *.

Once I built and booted the new kernel, I was able to passively profile an experimental DomU kernel by following these steps:

1. opcontrol --reset

2. opcontrol --start-daemon --xen=/boot/xen-syms-4.1.0-rc8 --vmlinux=/usr/lib/debug/lib/modules/2.6.32.34-175.xendom0.fc14.x86_64/vmlinux --passive-domains=1 --passive-images=/path/to/exp-kernel.elf

3. opcontrol --start

4. Run experiment

5. opcontrol --stop

6. opcontrol --shutdown

[1] http://fedoraproject.org/wiki/Features/XenPvopsDom0

[2] https://github.com/avsm/linux-2.6.32-xen-oprofile/commit/4df4780e638d14249b7aa4005511218a9183c324.patch

* To build the kernel, I:

1. Based my work on Michael Young's 2.6.32.34-175.xendom0.fc14.x86_64.

2. Modified config-generic to contain CONFIG_IGBVF=n, because this module failed to compile with GCC 4.6.

3. Added "%define with_perf 0" and "with_perftool 0" because perf would not compile with GCC 4.6.

4. Ran "depmod" and "dracut /boot/initramfs-VER.img VER" by hand.

Comment 3 Fedora Update System 2011-04-07 15:55:03 UTC
oprofile-0.9.6-20.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/oprofile-0.9.6-20.fc13

Comment 4 Fedora Update System 2011-04-07 15:56:51 UTC
oprofile-0.9.6-20.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/oprofile-0.9.6-20.fc14

Comment 5 Fedora Update System 2011-04-07 15:57:44 UTC
oprofile-0.9.6-20.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/oprofile-0.9.6-20.fc15

Comment 6 Fedora Update System 2011-04-08 23:17:58 UTC
Package oprofile-0.9.6-20.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing oprofile-0.9.6-20.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/oprofile-0.9.6-20.fc14
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-05-02 22:26:42 UTC
oprofile-0.9.6-20.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-05-02 22:29:28 UTC
oprofile-0.9.6-20.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-05-03 04:50:46 UTC
oprofile-0.9.6-20.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.