Bug 693598 - rhds82 rfe - windows_tot_run to log Sizelimit exceeded instead of LDAP error - -1
Summary: rhds82 rfe - windows_tot_run to log Sizelimit exceeded instead of LDAP error ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Rich Megginson
QA Contact:
URL:
Whiteboard:
Depends On: 693473
Blocks: 639035 389_1.2.8
TreeView+ depends on / blocked
 
Reported: 2011-04-05 02:27 UTC by Rich Megginson
Modified: 2011-09-16 21:33 UTC (History)
6 users (show)

Fixed In Version: ds-replication-1.2.8.0-1.el6
Doc Type: Enhancement
Doc Text:
Clone Of: 693473
Environment:
Last Closed: 2011-05-19 14:41:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0820 normal SHIPPED_LIVE new package: ds-replication 2011-05-19 14:41:19 UTC

Description Rich Megginson 2011-04-05 02:27:29 UTC
+++ This bug was initially created as a clone of Bug #693473 +++

Description of problem:

This is related to bz 692991 - rhds82 - windows_tot_run: failed to obtain data to send to the consumer; LDAP error - -1
and SFDC 00427819

A failed full init was resulting in RHDS reporting a generic LDAP error -1 
Having a hint about the sizelimit exceeded condition that was returned by AD would have saved hours trying to understand what was really happening.

Version-Release number of selected component (if applicable):
was report against redhat-ds-base-8.2.4-1.el5dsrv


How reproducible:
always in customer environment.


Steps to Reproduce:

not detailed steps, issue was not reproduced in house at the time of this report.

1. RHDS master
2. AD
3. specific data set, likely with "enough" policy or "other" entries in the sub tree to sync 
4. try a full init

  
Actual results:
in the customer environment, the full init had been failing always at the same place (after a few thousand entries)
Adding internal access and error logging took 10 hours to reach that point.


Expected results:

More detailed error processing, with an extra message in the case of the sizelimit exceeded condition that was returned by AD, so RHDS reports more helpful error instead of the generic LDAP error -1 


Additional info:

workaround: extend sizelimit for the AD user running the search.

error was:
windows_tot_run: failed to obtain data to send to the consumer; LDAP error - -1
error.

Edited notes:
An entry was already in RHDS, winsync tried to read the entry and compare.
windows_process_total_add() calls windows_get_remote_entry() which calls
windows_search_entry_ext() which calls ldap_search_ext_s() with a specific base 
and a scope of SCOPE_SUBTREE (-s sub).

In this particular case, a SIZELIMIT_EXCEEDED error was aborting the winsync init, and just returned an error -1.

--- Additional comment from rmeggins@redhat.com on 2011-04-04 21:35:10 EDT ---

Created attachment 489894 [details]
0002-Bug-693473-rhds82-rfe-windows_tot_run-to-log-Sizelim.patch

Comment 2 RHEL Product and Program Management 2011-04-05 02:43:27 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Amita Sharma 2011-05-08 07:42:50 UTC
Hi Rich,

As mentioned above, This is related to bz 692991 - rhds82 - windows_tot_run: failed to obtain data
to send to the consumer; LDAP error - -1

Which could never be reproduced, so should I do a sanity check for this also?
Please comment.

Thanks,
Amita

Comment 7 Rich Megginson 2011-05-09 13:12:55 UTC
(In reply to comment #6)
> Hi Rich,
> 
> As mentioned above, This is related to bz 692991 - rhds82 - windows_tot_run:
> failed to obtain data
> to send to the consumer; LDAP error - -1
> 
> Which could never be reproduced, so should I do a sanity check for this also?
> Please comment.
> 
> Thanks,
> Amita

Yes, just a sanity/winsync regression check for this.

Comment 8 errata-xmlrpc 2011-05-19 14:41:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0820.html

Comment 9 Chandrasekar Kannan 2011-09-16 21:33:15 UTC
ds-replication is no longer a component of rhel. folding back to 389-ds-base.


Note You need to log in before you can comment on or make changes to this bug.