Bug 693642 - ldap-agent-bin segfaults during start when denied access to /var/lib/net-snmp
ldap-agent-bin segfaults during start when denied access to /var/lib/net-snmp
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.1
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
: screened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-05 03:50 EDT by Karel Srot
Modified: 2015-01-04 18:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-13 19:32:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
abrt crash details (458.08 KB, application/x-gzip)
2011-04-05 03:50 EDT, Karel Srot
no flags Details

  None (edit)
Description Karel Srot 2011-04-05 03:50:44 EDT
Created attachment 489931 [details]
abrt crash details

Description of problem:

This was originaly caused by selinux-policy which denied the access to /var/lib/net-snmp (see bug 675782). This is already fixed and with proper policy you won't face this problem. 
But I don't think that ldap-agent-bin should segfault anyway.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install 389-ds-base
2. configure and start dirsrv using setup-ds.pl script
3. set up dirsrv server in /etc/dirsrv/config/ldap-agent.conf
4. start and kill "ldap-agent /etc/dirsrv/config/ldap-agent.conf"
   this is just to create necessary directories && files
5. chcon -R -t var_lib_t /var/lib/net-snmp/
6. ldap-agent /etc/dirsrv/config/ldap-agent.conf
  
Actual results:
ldap-agent: Not started after 15 seconds!  Check log file for details.
ldap-agent-bin segfaults

Expected results:
proper start

Additional info:
attached abrt logs

Note You need to log in before you can comment on or make changes to this bug.