Bug 69365 - Problem sending hardware profile
Summary: Problem sending hardware profile
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn_register (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217 79578
TreeView+ depends on / blocked
 
Reported: 2002-07-22 13:59 UTC by Gene Czarcinski
Modified: 2015-01-07 23:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 21:53:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2002-07-22 13:59:35 UTC
Description of Problem:
I ran rhn_register to register my system with limbo installed.  Everything
seemed to go OK (this was a new user registration) -- except for the "blank"
first screen.  When it got to the end and displayed the "Registration Progress"
panel, the progress bar went to 80% and then "hung".  After a few (five to ten)
minutes, the Progress Panel deleted and an error message popped up saying
"Problem sending hardware profile".  The userid/system was registered and
accessable from https://rhn.redhat.com/

Version-Release number of selected component (if applicable):
7.3.92

How Reproducible:
everytime ... for both existing userid and a new userid.

Steps to Reproduce:
1. Install Limbo
2. run rhn_register
3. 

Actual Results:
as above

Expected Results:
registration completes.

Additional Information:

Comment 1 Gene Czarcinski 2002-07-22 15:22:18 UTC
This "may" be related to 68104 but no traceback or anything ... it just "quits".

If 68104 tracks this problem, close this one as a dup.

Comment 2 Adrian Likins 2002-07-22 22:17:02 UTC
Definately sounds like the ssl upload issue to me. 

It seems to be the same issue as #68104 started as,
but that bug is a bit off track now it seems. 

#68911 is the root cause of it. Though there
are potentially other issues with proxys
and such (new network libs are such fun ;->)

I'm going to mark it as "MODIFED" at the moment
since I'm pretty sure the new rhnlib should take
care of this. If not, please reopenen of course.

Comment 3 Gene Czarcinski 2002-07-22 22:29:22 UTC
I had/have rhnlib-0.8-2 installed.

Comment 4 Jay Turner 2003-02-07 15:12:43 UTC
Gene, doing a little spring cleaning here (yes, I realize that it's February!)
and trying to figure out if you are still seeing issues with uploading hardware
profiles.

Comment 5 Gene Czarcinski 2003-02-07 17:17:35 UTC
Have not seen any problems lately.  When it works, it works.

I just blew away the system that was defined for testing rhn and 8.0.93 by
installing re0204.  It will take a little time but I can reconfigure another
systems and test if it is working.

More than likely, you can close this now.

Comment 6 Gene Czarcinski 2003-02-07 17:30:50 UTC
Ugh.

Just tried registering.  I got the following:

Problem sending hardware profile:
While running 'registration.add_hw_profile': caught
exceptions.KeyError : Unknwon class type `netinterfaces' for hardware '{'eth0':
{'module': 'natsemi',
'hwaddr': '00:02:e3:11:68:8d', 'ipaddr': '192.168.17.90', 'netmask':
'255.255.255.00', 'broadcast': '192.168.17.255'},
'lo': {'module': 'loopback', 'hwaddr': '00:00:00:00:00:00', 'ipaddr':
'127.00.00.01', 'netmask': '255.00.00.00',
'broadcast': '127.255.255.255'}, 'class': 'NETINTERFACES'}'

There is also report https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83347

which is for registering with DVD.

Mmmm.  This is a different problem.  Close this and I have opened a new one:
83731 against RHN.

Comment 7 Adrian Likins 2003-02-14 18:38:22 UTC
both bits of the tail of this bug should be fixed now.

Comment 8 Bill Nottingham 2003-07-28 21:53:49 UTC
Closing some bugs that have been in MODIFIED for a while. Please reopen if the
problem persists.


Note You need to log in before you can comment on or make changes to this bug.