Bug 693666 - [apache] "phantom" Main virtual host appears in the inventory if the URL of the Apache server is changed to https://serverName:port
[apache] "phantom" Main virtual host appears in the inventory if the URL of t...
Status: CLOSED DUPLICATE of bug 690435
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
3.0.1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-05 05:31 EDT by bkramer
Modified: 2011-10-04 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-13 17:07:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bkramer 2011-04-05 05:31:23 EDT
Description of problem:
A new Main virtual host appears in the inventory if the URL of the Apache server is changed from default one to https://serverName:port where serverName is the name used as a common name when creating a certificate.

Version-Release number of selected component (if applicable):
JON 2.4.1

How reproducible:
every time

Steps to Reproduce:
1. Discover and import the Apache instance (with SSL enabled) into JON inventory;
2. Go to Inventory -> Connection and change URL to https://serverName (where serverName is the name that is used to create a certificate);
3. Save the change and run "avail" command from the JON Agent command line;
  
Actual results:
a second virtual host called "Main" (with availability UP) appears in the
inventory with the resource key that match serverName.


Expected results:
There shouldn't be new virtual hosts.

Additional info:
This is probably a duplicate or very similar to:

https://bugzilla.redhat.com/show_bug.cgi?id=690435
Comment 1 Lukas Krejci 2011-06-13 17:07:24 EDT

*** This bug has been marked as a duplicate of bug 690435 ***

Note You need to log in before you can comment on or make changes to this bug.