Bug 6937 - rpm -Fvh freshens non-existent packages
rpm -Fvh freshens non-existent packages
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-11 16:13 EST by Mike Gerdts
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-11 16:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Gerdts 1999-11-11 16:13:06 EST
I did the following:

[mike@mlg-12-0 mike]$ rpm -q bind
package bind is not installed
[mike@mlg-12-0 mike]$ rpm -q bind-utils
bind-utils-8.2.1-7
[mike@mlg-12-0 mike]$ rpm -q bind-devel
package bind-devel is not installed[mike@mlg-12-0 mike]$ /bin/su
Password:
rpm -Fvh ftp://updates.redhat.com/6.1/i386/bind-8.2.2_P3-1.i386.rpm \
    ftp://updates.redhat.com/6.1/i386/bind-devel-8.2.2_P3-1.i386.rpm \
    ftp://updates.redhat.com/6.1/i386/bind-utils-8.2.2_P3-1.i386.rpm
Retrieving ftp://updates.redhat.com/6.1/i386/bind-8.2.2_P3-1.i386.rpm
Retrieving ftp://updates.redhat.com/6.1/i386/bind-devel-8.2.2_P3-1.i386.rpm
Retrieving ftp://updates.redhat.com/6.1/i386/bind-utils-8.2.2_P3-1.i386.rpm
bind                     ##################################################
bind-devel               ##################################################
bind-utils               ##################################################
[root@mlg-12-0 mike]# rpm -q bind
bind-8.2.2_P3-1

As I read rpm(8), bind and bind-devel should not have been installed.
Comment 1 Jeff Johnson 2000-08-10 02:09:28 EDT
I cannot reproduce this bug.

Note You need to log in before you can comment on or make changes to this bug.