Bug 693846 - GNOME Shell : Claws Mail starts with minimized window
Summary: GNOME Shell : Claws Mail starts with minimized window
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail
Version: 15
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL: http://www.thewildbeast.co.uk/claws-m...
Whiteboard:
Depends On: 693990
Blocks: 711257
TreeView+ depends on / blocked
 
Reported: 2011-04-05 18:07 UTC by Arne Ahrend
Modified: 2012-02-11 10:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-11 10:19:02 UTC


Attachments (Terms of Use)
drop the gtk_window_iconify call that does this (386 bytes, patch)
2011-04-05 21:01 UTC, Michael Schwendt
no flags Details | Diff
alternative patch that doesn't remove the iconify call (390 bytes, patch)
2011-04-06 09:09 UTC, Michael Schwendt
no flags Details | Diff
latest work-around from 3.7.10cvs55 (902 bytes, patch)
2011-11-01 12:39 UTC, Michael Schwendt
no flags Details | Diff

Description Arne Ahrend 2011-04-05 18:07:08 UTC
Description of problem:

claws-mail always opens in minimized state and has to be made visible by e.g. ALT+TAB.

Version-Release number of selected component (if applicable):
Claws Mail version 3.7.8cvs68, 3.7.9-0.1.20110329.fc15  

How reproducible:


Steps to Reproduce:
1. Log into Desktop (i.e. Gnome Shell)
2. Open claws-mail from Gnome Shell
3. Alternative: Open Terminal and type "claws-mail". No prompt is returned and claws-mail is running, but not immediately visible
  
Actual results:
No claws-mail window appears on starting claws-mail

Expected results:
claws-mail should come up with its main window

Additional info:

Comment 1 Michael Schwendt 2011-04-05 19:54:44 UTC
Confirmed. I had mentioned that in one of the several GNOME 3 related threads. It happened already with 3.7.8 (it's not new since 3.7.9-0.1.20110329.fc15).

Comment 2 Michael Schwendt 2011-04-05 21:01:16 UTC
Created attachment 490083 [details]
drop the gtk_window_iconify call that does this

F-15 scratch-build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2976670

Beyond that, no deep digging done yet.

Comment 3 Michael Schwendt 2011-04-06 09:09:46 UTC
Created attachment 490216 [details]
alternative patch that doesn't remove the iconify call

Comment 4 Fedora Update System 2011-04-10 11:24:22 UTC
libetpan-1.0.1-0.2.20110312cvs.fc14,claws-mail-3.7.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libetpan-1.0.1-0.2.20110312cvs.fc14,claws-mail-3.7.9-1.fc14

Comment 5 Fedora Update System 2011-04-10 11:24:33 UTC
libetpan-1.0.1-0.2.20110312cvs.fc15,claws-mail-3.7.9-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libetpan-1.0.1-0.2.20110312cvs.fc15,claws-mail-3.7.9-1.fc15

Comment 6 Fedora Update System 2011-04-11 20:59:19 UTC
Package libetpan-1.0.1-0.2.20110312cvs.fc14, claws-mail-plugins-3.7.9-2.fc14, claws-mail-3.7.9-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libetpan-1.0.1-0.2.20110312cvs.fc14 claws-mail-plugins-3.7.9-2.fc14 claws-mail-3.7.9-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/claws-mail-plugins-3.7.9-2.fc14,libetpan-1.0.1-0.2.20110312cvs.fc14,claws-mail-3.7.9-2.fc14
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-05-01 20:55:52 UTC
libetpan-1.0.1-0.2.20110312cvs.fc14, claws-mail-plugins-3.7.9-2.fc14, claws-mail-3.7.9-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-05-03 04:49:57 UTC
libetpan-1.0.1-0.2.20110312cvs.fc15, claws-mail-3.7.9-2.fc15, claws-mail-plugins-3.7.9-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Michael Schwendt 2011-06-08 16:26:43 UTC
The work-around patch causes several of Claws Mail's dialogs to not get focus, e.g. bug 711257. Reopening.

Comment 10 Michael Schwendt 2011-06-08 16:40:10 UTC
This seems to work, too, without causing bug 711257:

diff --git a/claws-mail-3.7.9cvs2.patch b/claws-mail-3.7.9cvs2.patch
index 799b8de..d2b895f 100644
--- a/claws-mail-3.7.9cvs2.patch
+++ b/claws-mail-3.7.9cvs2.patch
@@ -5,7 +5,7 @@ diff -up claws-mail-3.7.9/src/mainwindow.c.orig claws-mail-3.7.9
        if (first_start) {
  #ifdef G_OS_UNIX
                gtk_window_deiconify(GTK_WINDOW(mainwin->window));
-+              gtkut_window_popup(mainwin->window);
++              gtk_widget_show(GTK_WINDOW(mainwin->window));
  #endif
                first_start = FALSE;
        } else {

Comment 11 Michael Schwendt 2011-06-08 16:42:52 UTC
only sometimes it seems :/

Comment 12 Michael Schwendt 2011-06-09 13:10:53 UTC
claws-mail-3.7.9-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/claws-mail-3.7.9-4.fc15

Comment 13 Michael Schwendt 2011-11-01 12:39:44 UTC
Created attachment 531121 [details]
latest work-around from 3.7.10cvs55

This is a new work-around from Claws Mail 3.7.10cvs55. Seems to work. Also makes the Tray Icon "hide at start" feature work again. No side-effects noticed so far.


Note You need to log in before you can comment on or make changes to this bug.