Bug 693875 - [6.2 FEAT] virt-manager: include 802.1Qbg support
[6.2 FEAT] virt-manager: include 802.1Qbg support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager (Show other bugs)
6.2
x86_64 All
medium Severity medium
: rc
: 6.2
Assigned To: Cole Robinson
Virtualization Bugs
: FutureFeature, OtherQA, Rebase
: 693870 (view as bug list)
Depends On:
Blocks: 659725 693512 638197
  Show dependency treegraph
 
Reported: 2011-04-05 15:31 EDT by IBM Bug Proxy
Modified: 2011-12-12 12:47 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
New Feature: virt-manager now allows editting 802.11qbg virtualport settings for direct interfaces.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 11:07:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
support to select the mode for direct interfaces (11.44 KB, text/plain)
2011-06-10 18:14 EDT, IBM Bug Proxy
no flags Details
support for passthrough mode for direct interfaces (779 bytes, text/plain)
2011-06-10 18:14 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 71038 None None None Never

  None (edit)
Description IBM Bug Proxy 2011-04-05 15:31:19 EDT
1. Feature Overview:
Feature Id: [71038]
a. Name of Feature: [6.2 FEAT] virt-manager: include 802.1Qbg support
b. Feature Description
Commit ababf7acec29191179a597e7349a9c4ce55492a6 to the virt-manager git adds the following feature:
editting virtualport settings for 'direct' nic. This patch adds support for VSI types so the
respective values can be viewed and edited via virt-manager

2. Feature Details:
Sponsor: LTC
Architectures:  x86_64, 
Arch Specificity: both
Affects Kernel Modules: No
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Feature from Upstream
d. Upstream Acceptance: Accepted
Sponsor Priority P3
f. Severity: normal
IBM Confidential: No
Code Contribution: unsure
g. Component Version Target: ---

3. Business Case
This feature allows the use of virt-manager in a Qbg enabled environment and to explore Qbg
possibilities.
The alternative is to use virsh to edit VSI types in the domain xml, which is inconvenient for the user.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie A. Glass, sglass@us.ibm.com

Technical contact(s):
Gerhard Stenzel, gerhard.stenzel@de.ibm.com
Comment 2 RHEL Product and Program Management 2011-04-05 15:43:59 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 3 Cole Robinson 2011-04-07 13:03:43 EDT
As mentioned, this is already upstream, but probably warrants a rebase for 6.2
Comment 5 IBM Bug Proxy 2011-05-10 12:20:23 EDT
------- Comment From gerhard.stenzel@de.ibm.com 2011-05-10 12:14 EDT-------
(In reply to comment #5)
> As mentioned, this is already upstream, but probably warrants a rebase for 6.2

For clarification, does above statement mean virt-manager will be rebased for 6.2?
If yes, to which level?
Comment 6 Cole Robinson 2011-05-10 13:50:59 EDT
Not official yet, but I'm almost positive virt-manager will be rebased in 6.2, probably to a version that hasn't been released yet.
Comment 7 Cole Robinson 2011-06-10 18:08:55 EDT
*** Bug 693870 has been marked as a duplicate of this bug. ***
Comment 8 IBM Bug Proxy 2011-06-10 18:14:52 EDT
Created attachment 504212 [details]
support to select the mode for direct interfaces
Comment 9 IBM Bug Proxy 2011-06-10 18:14:57 EDT
Created attachment 504213 [details]
support for passthrough mode for direct interfaces
Comment 13 John Jarvis 2011-06-23 11:00:08 EDT
IBM is signed up to test and provide feedback for this feature request.
Comment 16 Cole Robinson 2011-07-28 11:31:00 EDT
Fixed in virt-manager-0.9.0-2.el6
Comment 18 IBM Bug Proxy 2011-07-28 16:50:29 EDT
------- Comment From gerhard.stenzel@de.ibm.com 2011-07-28 16:40 EDT-------
Cole, thank you.
Is virt-manager-0.9.0-2.el6 downloadable from somewhere?
Comment 21 IBM Bug Proxy 2011-09-21 04:11:09 EDT
------- Comment From gerhard.stenzel@de.ibm.com 2011-09-21 04:04 EDT-------
6.2 alpha contains virt-manager 0.9.0-6 which diplays the requested Qbg fields .. thank you
Comment 22 min zhan 2011-09-23 04:05:18 EDT
Move it to VERIFIED per Comment 21.
Comment 23 Cole Robinson 2011-11-07 17:33:58 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
New Feature:
virt-manager now allows editting 802.11qbg virtualport settings for direct interfaces.
Comment 24 errata-xmlrpc 2011-12-06 11:07:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html

Note You need to log in before you can comment on or make changes to this bug.