Bug 693881 - A fatal error occurred when installing the lockdev package.
Summary: A fatal error occurred when installing the lockdev package.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lockdev
Version: 15
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-05 19:49 UTC by Andrew McNabb
Modified: 2011-04-06 15:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-06 15:56:11 UTC
Type: ---


Attachments (Terms of Use)

Description Andrew McNabb 2011-04-05 19:49:10 UTC
I'm installing Fedora 15 Alpha with the updates-testing repository enabled. When Anaconda tries to install lockdev-1.0.3-9.fc15.x86_64, it gives the error, "A fatal error occurred when installing the lockdev package. This could indicate errors when reading the installation media. Installation cannot continue. Exit installer" In /mnt/sysimage/root/install.log, I see:

Installing lockdev-1.0.3-9.fc15.x86_64
error: unpacking of archive failed on file /var/lock/lockdev: cpio: mkdir failed - Resource temporarily unavailable

I have tried installing 3 or 4 times, and I have encountered this error every time. I seem to be unable to complete an installation.

I can't think of any user error that might be causing this, but it's always possible. If this problem is affecting others as well, it might turn out to be very serious. Right now I'm unable to finish installing as it forces me to click the "Exit installer" button. Is there any other information that would be helpful? Thanks.

Comment 1 Ondrej Vasik 2011-04-06 10:42:32 UTC
What is the version of filesystem package in install.log ? If filesystem-2.4.39-1.fc15 , then it is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=693394 ... if something different, problem might be in different place.

Comment 2 Andrew McNabb 2011-04-06 15:56:11 UTC
So I just tried installing again, and this time lockdev installed properly (with filesystem-2.4.37-1.fc15.x86_64). Anyway, it looks like some update has been pushed since I filed this, so I'll go ahead and close it.


Note You need to log in before you can comment on or make changes to this bug.