This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 694001 - Unable to use "VGA passthrough" function
Unable to use "VGA passthrough" function
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
14
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-06 04:47 EDT by Daniel Fages
Modified: 2011-05-24 22:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: xen-4.0.1-11.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-24 22:39:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Fages 2011-04-06 04:47:05 EDT
Description of problem:
When I want to use the "VGA passthrough" function Xen by having the "gfx_passthru=1" in my HVM configuration, the corresponding domain won't start.
After some work, this is due to the fact that the Xen Python try to start "qemu-dm" with the "--gfx_passthru 1" option whereas it just should be "--gfx_passthru".


Version-Release number of selected component (if applicable): 4.0.1


How reproducible:
Configure a VM with GFX passthru

Steps to Reproduce:
1. Add gfx_passthru=1 to a VM configuration file
2. Try to start the VM
3.
  
Actual results:
The VM won't start

Expected results:
The VM to start with VGA passthrough function enabled

Additional info:
This is the patch I propose to correct the problem (for the 64-bit package, should be the same for the 32-bit one after chaning the file path):
--- usr/lib64/python2.7/site-packages/xen/xend/image.py	2011-03-23 10:29:53.946082001 +0100
+++ usr/lib64/python2.7/site-packages/xen/xend/image.py	2011-03-23 10:30:18.192082001 +0100
@@ -865,7 +865,7 @@
             if a == 'keymap': a = 'k'
 
             # Handle booleans gracefully
-            if a in ['localtime', 'std-vga', 'isa', 'usb', 'acpi']:
+            if a in ['localtime', 'std-vga', 'isa', 'usb', 'acpi', 'gfx_passthru']:
                 try:
                     if v != None: v = int(v)
                     if v: ret.append("-%s" % a)
Comment 1 Fedora Update System 2011-05-10 17:36:02 EDT
xen-4.0.1-11.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xen-4.0.1-11.fc14
Comment 2 Fedora Update System 2011-05-13 19:06:33 EDT
Package xen-4.0.1-11.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xen-4.0.1-11.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/xen-4.0.1-11.fc14
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2011-05-24 22:39:24 EDT
xen-4.0.1-11.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.