Bug 694079 - GDM starts while firstboot is still running
GDM starts while firstboot is still running
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 694290 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-04-06 07:49 EDT by James Laska
Modified: 2013-09-02 02:55 EDT (History)
12 users (show)

See Also:
Fixed In Version: systemd-24-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-08 22:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (systemd.log_level=debug) (764.05 KB, text/plain)
2011-04-06 07:49 EDT, James Laska
no flags Details
/var/log/messages (systemd.log_level=debug) (197.68 KB, text/plain)
2011-04-06 08:35 EDT, James Laska
no flags Details
dmesg (systemd.log_level=debug systemd.log_target=kmsg) (123.29 KB, text/plain)
2011-04-06 09:48 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2011-04-06 07:49:59 EDT
Created attachment 490244 [details]
/var/log/messages (systemd.log_level=debug)

Description of problem:


Version-Release number of selected component (if applicable):
 * firstboot-1.117-2.fc15.x86_64
 * gdm-3.0.0-1.fc15.x86_64
 * systemd-22-1.fc15.x86_64


How reproducible:
 * Seems like everytime now (also confirmed by kparal on test@lists.fp.org)

Steps to Reproduce:
1. Install Fedora 15 Beta TC1 (enable updates-testing)
2. Select default package installation
3. After install, boot into installed system
4. Proceed through firstboot
  
Actual results:

GDM starts while firstboot is still running.  This happens either when ...
 1) Clicking "Apply" on the Network Authentication Configuration dialog
    OR
 2) When transitioning to the "Hardware Profile" screen


Expected results:

GDM should not start until after the user selects "Finish" from the hardware profile screen.

Additional info:

 * See attached /var/log/messages with systemd.log_level=debug
Comment 1 James Laska 2011-04-06 08:35:40 EDT
Created attachment 490255 [details]
/var/log/messages (systemd.log_level=debug)

Version-Release number of selected component (if applicable):
 * firstboot-1.117-2.fc15.x86_64
 * selinux-policy-3.9.16-12.fc15.noarch
 * systemd-23-1.fc15.x86_64
 * filesystem-2.4.40-1.fc15.x86_64

Updated /var/log/messages attached
Comment 2 James Laska 2011-04-06 09:48:16 EDT
Created attachment 490283 [details]
dmesg (systemd.log_level=debug systemd.log_target=kmsg)
Comment 3 Jóhann B. Guðmundsson 2011-04-06 10:37:27 EDT
Basically what's happening here is that the prefdm.service is getting started for some reason.

I suspect that the TimeoutSec=0 which disables the timeout login is broken in recent systemd versions which results in firstboot-graphical.service being killed after the default 60 seconds and prefdm.service to start

Could you test with systemd 19-1 to see if it works and if my suspicion is correct test up to 22-1 so we can narrow it down in which release it breaks.

Thanks
Comment 4 James Laska 2011-04-06 10:53:49 EDT
(In reply to comment #3)
> Basically what's happening here is that the prefdm.service is getting started
> for some reason.

I spoke to Lennart on IRC and he's identified the cause of this bug already.  A fix is inprogress.
Comment 5 Lennart Poettering 2011-04-06 13:23:47 EDT
Fix is in git.
Comment 7 James Laska 2011-04-06 14:55:15 EDT
Depending on which failure scenario you hit from comment#0, I believe this qualifies as a Beta release blocker due to the following Alpha release criteria [1].

When it comes to using the authconfig-gtk to create a user account in firstboot ...

    "In most cases (see Blocker_Bug_FAQ), a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied."

When it comes to gdm starting while firstboot transitions to the hardware profile page, and firstboot never completes, so it will *always* start on boot ...

    "The firstboot utility must be able to create a working user account Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied"


[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 8 Robyn Bergeron 2011-04-06 15:39:02 EDT
+1 to being a beta blocker.
Comment 9 Dennis Gilmore 2011-04-06 16:09:01 EDT
+1 to being a blocker
Comment 10 Fedora Update System 2011-04-06 16:14:58 EDT
systemd-24-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/systemd-24-1.fc15
Comment 11 Fedora Update System 2011-04-06 22:21:15 EDT
Package systemd-24-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-24-1.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/systemd-24-1.fc15
then log in and leave karma (feedback).
Comment 12 James Laska 2011-04-07 09:45:12 EDT
Confirmed fix using systemd-24-1.fc15.  GDM starts only after firstboot has run to completion
Comment 13 Lennart Poettering 2011-04-07 11:23:52 EDT
*** Bug 694290 has been marked as a duplicate of this bug. ***
Comment 14 James Laska 2011-04-08 14:48:06 EDT
Discussed during the 2011-04-08 blocker review meeting [1].  AcceptedBlocker for Beta. Impacted Alpha criteria by preventing user creation in firstboot or running firstboot on every boot.

[1] http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-08/f-15-beta-blocker-review.2011-04-08-17.00.html
Comment 15 Fedora Update System 2011-04-08 22:12:26 EDT
systemd-24-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.