This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 694454 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ypbind (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-07 08:42 EDT by Jóhann B. Guðmundsson
Modified: 2011-06-15 15:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 04:50:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for ypbind (365 bytes, text/plain)
2011-04-07 08:42 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for ypbind (440 bytes, application/octet-stream)
2011-04-14 10:40 EDT, Honza Horak
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-07 08:42:04 EDT
Created attachment 490532 [details]
Native systemd service file for ypbind

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Honza Horak 2011-04-14 10:40:46 EDT
Created attachment 492134 [details]
Native systemd service file for ypbind

This is a new systemd service file for ypbind, which works together with scripts ypbind-pre-setdomain and ypbind-post-waitbind. 

There is a complete build in Rawhide to test: http://koji.fedoraproject.org/koji/buildinfo?buildID=238998
Comment 2 Bill Nottingham 2011-04-26 13:35:29 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 3 kwyjibo 2011-06-06 11:50:15 EDT
This latest service file fails on systems with selinux disabled.

The setsebool command returns a 1 if selinux is disabled which creates a failed start of the service.
Comment 4 Jóhann B. Guðmundsson 2011-06-06 14:00:50 EDT
Does adding "-" to the ExecStartPre= line fix the problem as in..

[Unit]
Description=The ypbind daemon which binds NIS/YP clients to NIS domain
After=syslog.target network.target rpcbind.service

[Service]
EnvironmentFile=-/etc/sysconfig/network
EnvironmentFile=-/etc/sysconfig/ypbind
ExecStartPre=-/usr/lib/ypbind/ypbind-pre-setdomain ; /usr/sbin/setsebool allow_ypbind=1 
ExecStart=/usr/sbin/ypbind -f $OTHER_YPBIND_OPTS
ExecStopPost=/usr/sbin/setsebool allow_ypbind=0 ; /usr/lib/ypbind/ypbind-post-waitbind

[Install]
WantedBy=multi-user.target
Comment 5 Honza Horak 2011-06-07 04:50:41 EDT
(In reply to comment #3)
> This latest service file fails on systems with selinux disabled.

Thanks for the notice. The following change fixes the failure.

-ExecStartPre=/usr/lib/ypbind/ypbind-pre-setdomain ; /usr/sbin/setsebool allow_ypbind=1 
+ExecStartPre=-/usr/lib/ypbind/ypbind-pre-setdomain
+ExecStartPre=-/usr/sbin/setsebool allow_ypbind=1

A new build with this fix is available here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=246603

Since this bug has been moved to Rawhide I'm closing this for now. Feel free to re-open it if needed.

Note You need to log in before you can comment on or make changes to this bug.