Bug 69447 - compiling kernel: make mrproper deletes autoconf.h
compiling kernel: make mrproper deletes autoconf.h
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 13:25 EDT by Mark Sobell
Modified: 2007-04-18 12:44 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:04:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Sobell 2002-07-22 13:25:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When I install kernel-source-2.4.18-5.58.i386.rpm and run make mrproper it 
removes include/linux/autoconf.h. Then, after creating a .config file, when I 
run make dep it complains about not having a rule to create autoconf.h and 
aborts.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install kernel-source-2.4.18-5.58.i386.rpm 
2.run make mrproper
3.create a .config file
4.run make dep
	

Actual Results:  make[1]: Entering directory `/usr/src/linux-2.4.18-5.58'
make -C kernel fastdep
make[2]: Entering directory `/usr/src/linux-2.4.18-5.58/kernel'
make[2]: *** No rule to make target `/usr/src/linux-2.4.18-5.58/include/linux/au
toconf.h', needed by `/usr/src/linux-2.4.18-5.58/include/linux/modules/signal.ve
r'.  Stop.
make[2]: Leaving directory `/usr/src/linux-2.4.18-5.58/kernel'
make[1]: *** [_sfdep_kernel] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.18-5.58'
make: *** [dep-files] Error 2
[root@grape linux-2.4.18-5.58]#

Expected Results:  make dep should have run to completion

Additional info:
Comment 1 Arjan van de Ven 2002-07-22 13:28:06 EDT
How did you create the config file?
It must be created by either make oldconfig, make config, make menuconfig or
make xconfig. Any other way indeed doesn't do autoconf.h but there's more stuff
like that needed...
Comment 2 Mark Sobell 2002-07-22 13:49:36 EDT
I used KDE Control Center: System -> Linux Kernel Configurator.
When I used make oldconfig and make menuconfig everything was fine.
When I tried make xconfig I got an error saying <make: wish: Command not found>
Comment 3 Arjan van de Ven 2002-07-22 13:52:04 EDT
for xconfig you need the tk packages; however this looks like a KDE bug... or at
least you need to run make oldconfig on the KDE generated config file.
Comment 4 Mark Sobell 2002-07-22 22:20:05 EDT
So I need to tell my readers that they must install tk packages if they want to 
run xconfig? Sounds strange. What are the names of the packages?

Also, how would I run make oldconfig on a .config file? With my custom .config 
I had to run make config and just hold the RETURN key down. Is there an easier 
way?

Then I ran into another problem. When I ran make install I got this message on 
the last step:

sh -x ./install.sh 2.4.18-5.58customB bzImage /usr/src/linux-2.4.18-5.58/System.
map ""
+ '[' -x /root/bin/installkernel ']'
+ '[' -x /sbin/installkernel ']'
+ exec /sbin/installkernel 2.4.18-5.58customB bzImage /usr/src/linux-2.4.18-5.58
/System.map ''
fatal error: unable to find a suitable template
make[1]: Leaving directory `/usr/src/linux-2.4.18-5.58/arch/i386/boot'
[root@grape linux-2.4]#

This error only seems to occur when there is a /boot/grub/grub.conf file 
present. I renamed grub.conf, ran make install without a problem, and put 
grub.conf back in place and set up a new entry for the new kernel by hand.

Hope that helps.

        Mark


Comment 5 Petr Rockai 2006-07-17 14:25:32 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 6 Bill Nottingham 2006-10-18 14:04:51 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.