This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 694480 - [6.2 FEAT] Update libvirt-cim to a version that supports the QEMU vTPM (anticipating 0.8.5)
[6.2 FEAT] Update libvirt-cim to a version that supports the QEMU vTPM (antic...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt-cim (Show other bugs)
6.3
All All
medium Severity medium
: beta
: 6.3
Assigned To: Daniel Veillard
Virtualization Bugs
: FutureFeature, Rebase
Depends On:
Blocks: 704634 705085
  Show dependency treegraph
 
Reported: 2011-04-07 09:33 EDT by IBM Bug Proxy
Modified: 2012-01-04 16:24 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-04 16:19:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 71255 None None None Never

  None (edit)
Description IBM Bug Proxy 2011-04-07 09:33:23 EDT
1. Feature Overview:
Feature Id: [71255]
a. Name of Feature: [6.2 FEAT] Update libvirt-cim to a version that supports the QEMU vTPM
(anticipating 0.8.5)
b. Feature Description
Please update libvirt-cim to 0.5.9 or a version that supports the QEMU vTPM (unsure which version
the patches will hit): http://libvirt.org/downloads.html

2. Feature Details:
Sponsor: LTC Security
Architectures:  IA_64, ppc64, x86, x86_64, zSeries - 31/32 compat, zSeries - 31/32 Native, zSeries -
64 native, 
Arch Specificity: purely common code
Affects Kernel Modules: No
Delivery Mechanism: Direct from Community
Category: other
Request Type: Package - Feature from Upstream
d. Upstream Acceptance: Submitted
Sponsor Priority P2
f. Severity: normal
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target: ---

3. Business Case
This feature is necessary to integrate IBM's Software Trusted Platform Module to QEMU.  The vTPM is
a necessary component to establish end-to-end integrity for QEMU guests via Trusted Computing.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Stephanie A. Glass, sglass@us.ibm.com

Technical contact(s):
George C. Wilson, gcwilson@us.ibm.com
Comment 2 RHEL Product and Program Management 2011-04-07 09:43:51 EDT
Since RHEL 6.1 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.
Comment 5 IBM Bug Proxy 2011-05-26 06:10:23 EDT
------- Comment From sglass@us.ibm.com 2011-05-26 06:09 EDT-------
Redhat, this feature is not ready and needs to be deferred to RHEL 6.3.  Thanks
Comment 7 IBM Bug Proxy 2011-12-08 10:22:50 EST
------- Comment From sglass@us.ibm.com 2011-12-08 10:11 EDT-------
Red Hat, please quit this feature.  We already have a feature for RHEL 7 for this item which is when we will do the work.
Comment 8 Dave Allan 2012-01-04 16:19:22 EST
(In reply to comment #7)
> ------- Comment From sglass@us.ibm.com 2011-12-08 10:11 EDT-------
> Red Hat, please quit this feature.  We already have a feature for RHEL 7 for
> this item which is when we will do the work.

Ok, closing.

Note You need to log in before you can comment on or make changes to this bug.