Bug 694499 - Cannot reboot at the end of the install, only shutdown is possible
Cannot reboot at the end of the install, only shutdown is possible
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2011-04-07 10:05 EDT by Jan Stodola
Modified: 2013-01-09 21:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-23 01:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb-all.log (493.81 KB, text/plain)
2011-04-07 10:05 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2011-04-07 10:05:48 EDT
Created attachment 490556 [details]
anaconda-tb-all.log

Description of problem:
At the end of the installation on s390x, anaconda should ask user to reboot into installed system. Instead of this, anaconda shows only "Shutdown" button. Messages on the screen says:

Congratulations, your Fedora
installation is complete.

Please shutdown to use the installed
system.

Error determining boot device's disk
name


/boot is stored on a logical volume, which should be valid configuration (at least RHEL6.1 supports it).
I can't see anything suspicious in logs or terminal, anaconda-tb-all.log is attached.

After shutdown and IPL from the DASD drive, system boots.


Following was executed before shutting down the install:

-bash-4.2# chroot /mnt/sysimage/ /bin/sh
sh-4.2# /lib/s390-tools/zipl_helper.device-mapper /boot/
targetbase=94:4
targettype=CDL
targetgeometry=13356,15,12
targetblocksize=4096
targetoffset=131352

sh-4.2# ls -l /dev/ | grep 94
brw-rw----. 1 root disk     94,   4 Apr  7 08:40 dasdb
brw-rw----. 1 root disk     94,   5 Apr  7 09:32 dasdb1

sh-4.2# pvs
  PV          VG      Fmt  Attr PSize PFree  
  /dev/dasdb1 vg_rtt6 lvm2 a-   9.16g 480.00m
sh-4.2# vgs
  VG      #PV #LV #SN Attr   VSize VFree  
  vg_rtt6   1   3   0 wz--n- 9.16g 480.00m
sh-4.2# lvs
  LV       VG      Attr   LSize   Origin Snap%  Move Log Copy%  Convert
  LogVol02 vg_rtt6 -wi-ao 512.00m                                      
  lv_boot  vg_rtt6 -wi-ao 512.00m                                      
  lv_root  vg_rtt6 -wi-ao   7.69g

Version-Release number of selected component (if applicable):
anaconda-15.25

How reproducible:
always

Steps to Reproduce:
1. run installation with partitioning described above, minimal package set
  
Actual results:
User can only shutdown the guest at the end of the installation.

Expected results:
Rebooting into installed system is possible.
Comment 1 David Cantrell 2011-04-18 13:16:23 EDT
This happens is 'chreipl' is unable to set the reIPL device.  What are you installing on and what does the storage layout look like?
Comment 2 Jan Stodola 2011-05-11 13:09:09 EDT
Clearing needinfo, since David had a chance to investigate on the system before rebooting.
Please, let me know if any additional info or testing is needed.
Comment 3 Jesse Keating 2012-05-23 01:40:34 EDT
I'm not seeing this on F17 installs.  Please re-open if you see it again.

Note You need to log in before you can comment on or make changes to this bug.