Bug 69452 - Inconsistent behaviour of "reboot" and "halt" with manual page
Summary: Inconsistent behaviour of "reboot" and "halt" with manual page
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: usermode   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-22 18:12 UTC by Peter van Egdom
Modified: 2007-04-18 16:44 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 01:52:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter van Egdom 2002-07-22 18:12:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020719

Description of problem:
When I use the commands "reboot" and "halt" as a normal (not root) user, 
nothing happens.

According to the manual page, the following should occur (I quote..) :

" DIAGNOSTICS
        If  youbre  not  the  superuser,  you will get the message
        bmust be superuserb. "



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type "halt" or "reboot" as a normal user.
2.
3.
	

Actual Results:  Nothing happens.

Expected Results:  "must be superuser" (or something similar).

Additional info:

Source RPM: usermode-1.55-4.src.rpm

Comment 1 Nalin Dahyabhai 2002-07-24 01:23:32 UTC
This will be fixed in 1.56 and later.

Comment 2 Jay Turner 2002-07-31 02:48:50 UTC
Fix confirmed with usermode-1.56-2.

Comment 3 Peter van Egdom 2002-07-31 19:39:46 UTC
Reopening this bug.

I tested this on a freshly installed Red Hat Linux box (Limbo beta 2 - 7.3.93)
and a normal user (without super-user rights) is still able to reboot or halt
a machine with resp. the commands "reboot" or "halt".

Whether the user is created during installation with Anaconda or after
installation with "useradd <foobar>" does not matter.


Additional info :

[peterve@limbo-pc peterve]$ which reboot
/usr/bin/reboot

[peterve@limbo-pc peterve]$ ls -l /usr/bin/reboot
lrwxrwxrwx    1 root     root           13 jul 31 00:04 /usr/bin/reboot ->
 consolehelper

[peterve@limbo-pc peterve]$ which consolehelper
/usr/bin/consolehelper

[peterve@limbo-pc peterve]$ rpm -qfi /usr/bin/consolehelper |grep RPM
Group       : Applications/System         Source RPM: usermode-1.56-2.src.rpm


Comment 4 Nalin Dahyabhai 2002-08-06 01:52:43 UTC
Two different bugs, it appears.  The first (no error message) is fixed here. 
The second is part of how usermode works (users who are logged in on the system
console are allowed to reboot or halt the system based on the assumption that
she can just yank the power cord to accomplish the same goal).  To disable that
functionality, you'll need to remove the usermode package altogether.  To that
end, I'm leaning to re-closing this bug.

Comment 5 Nalin Dahyabhai 2002-08-13 20:45:15 UTC
Closing because the original bug here is fixed in Raw Hide.


Note You need to log in before you can comment on or make changes to this bug.