Bug 69463 - desktop file fixes
desktop file fixes
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: pan (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: FutureFeature
: 70731 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-22 14:39 EDT by Havoc Pennington
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 02:09:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Havoc Pennington 2002-07-22 14:39:41 EDT
Needs Categories including at least X-Red-Hat-Extra;Internet;Application;

Comment need not reiterate the "pan" part, maybe 
"Read Usenet news articles"

move to /usr/share/applications

Namespace the desktop filename, "net-pan.desktop"
Comment 1 Bill Huang 2002-07-24 23:34:46 EDT
As for "Comment"."A News Reader" is better.Since it can be used to read any
kinds of news from many newgroup server,not only usenet.
As for the name of desktop, gnome-pan.desktop is better.It takes the same style
like other gnome applications such as gnome-dictionary.desktop.
Comment 2 Bill Huang 2002-07-24 23:37:21 EDT
Do you plan to move all the gnome/internet applications to
/usr/share/applications without more directories?


[bhuang@station111 pan-0.12.0]$ ls  /usr/share/gnome/apps/Internet/
balsa.desktop     gaim.desktop    gftp.desktop  pan.desktop
ethereal.desktop  galeon.desktop  gq.desktop
[bhuang@station111 pan-0.12.0]$
Comment 3 Havoc Pennington 2002-07-24 23:50:22 EDT
The Comment field should be a verb phrase such as "Read Internet news" rather than
a description such as "A News Reader"

The namespace is for the vendor of the desktop file, the GNOME project does not
ship Pan - so net-pan.desktop would be preferred. gnome- prefix is for things
that GNOME ships, not everything that links to GNOME libraries.

All desktop files should indeed be moved to /usr/share/applications/, separate
bugs have been filed for each desktop file.
Comment 4 Jens Petersen 2002-08-08 02:09:17 EDT
*** Bug 70731 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2002-08-09 00:33:04 EDT
Should be fixed in pan-0.12.1-2.

Note You need to log in before you can comment on or make changes to this bug.