Bug 694694 - [RFE] requests spice-gtk build for RHEL
[RFE] requests spice-gtk build for RHEL
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.2
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
: FutureFeature
Depends On:
Blocks: 693512 680060 680213
  Show dependency treegraph
 
Reported: 2011-04-07 23:16 EDT by Vivian Bian
Modified: 2011-12-06 10:06 EST (History)
14 users (show)

See Also:
Fixed In Version: spice-gtk-0.6-2.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 10:06:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vivian Bian 2011-04-07 23:16:09 EDT
Description of problem:
From our virt-manager point of view, we need the spice-gtk built on RHEL desktop to make sure spice graphical interface could be accessed from virt-manager and virt-viewer . 

Version-Release number of selected component (if applicable):
RHEL 6.1 

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vivian Bian 2011-04-07 23:16:46 EDT
Since there isn't an exact spice-gtk component in BZ . So file this bug on spice-server first .
Comment 2 Vivian Bian 2011-04-07 23:18:22 EDT
Since now it is late for 6.1 build to fix this problem, request to fix it on 6.2
Comment 4 David Jaša 2011-05-19 09:01:45 EDT
I've tried to build spice-gtk from upstream git ( git://gitorious.org/spice-gtk/spice-gtk.git ) on my RHEL-nightly laptop. I needed to backport this stuff:

* gtk-introspection - included in build system, but not included in RHEL 6 builds: 
https://brewweb.devel.redhat.com/packageinfo?packageID=14420

* RHEL vala is stuck at 0.7 series and it isn't shipped:
https://brewweb.devel.redhat.com/packageinfo?packageID=17605
EPEL vala is at 0.10.4:
http://koji.fedoraproject.org/koji/packageinfo?packageID=4055
so it would be necessary to update it o 0.11.7 and push it to RHEL

Maybe there was something more I didn't notice as I backported other packages to the system earlier.
Comment 5 Christophe Fergeau 2011-05-19 09:35:34 EDT
These requirements are only needed when building from git, if you get a tarball, gobject-introspection is optional, and vala won't be needed since the tarball will contain the preprocessed .c files.
Comment 6 Christophe Fergeau 2011-05-25 07:07:09 EDT
For what it's worth, I've prepared spice-gtk 0.6 packages for rawhide and epel6 which I hope to be able to push shortly (some time today or tomorrow). Vivian, would an EPEL package be enough for your testing for now?
Comment 7 Christophe Fergeau 2011-05-27 10:43:20 EDT
It's being built on http://koji.fedoraproject.org/koji/taskinfo?taskID=3096144
Comment 10 Christophe Fergeau 2011-08-05 11:56:18 EDT
There's now a spice-gtk build in 6.2, see https://brewweb.devel.redhat.com/packageinfo?packageID=32830
Comment 13 Gianluca Cecchi 2011-11-16 12:24:45 EST
Hello,
where to find spicy in rh el 6.2 beta?
Installed spice-gtk-0.6-2.el6.x86_64.rpm but
# rpm -ql spice-gtk
/usr/lib64/libspice-client-gtk-2.0.so.1
/usr/lib64/libspice-client-gtk-2.0.so.1.1.0
/usr/share/doc/spice-gtk-0.6
/usr/share/doc/spice-gtk-0.6/AUTHORS
/usr/share/doc/spice-gtk-0.6/COPYING
/usr/share/doc/spice-gtk-0.6/NEWS
/usr/share/doc/spice-gtk-0.6/README

No spice-gtk-tools as in Fedora?
I see anyway that in spice-gtk-python-0.6-2.el6.x86_64.rpm there is the module to use spice inside virt-manager
Thanks,
Gianluca
Comment 14 David Jaša 2011-11-16 19:10:17 EST
(In reply to comment #13)
> No spice-gtk-tools as in Fedora?

If you can not find spice-gtk-tools in any repository, you can get it by rebuilding spice-gtk source package.
Comment 15 Gianluca Cecchi 2011-11-17 03:13:42 EST
Is there any particular reason why in current build setup for the new spice-gtk package as in 6.2 beta, spice-gtk-tools is not generated?
Comment 16 Christophe Fergeau 2011-11-21 06:55:32 EST
spice-gtk-tools is available from the "optional" 6.2 repository
Comment 17 errata-xmlrpc 2011-12-06 10:06:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1610.html

Note You need to log in before you can comment on or make changes to this bug.