Bug 694716 - 15 Beta RC1 DVDs fail repoclosure
15 Beta RC1 DVDs fail repoclosure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
AcceptedBlocker
:
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-04-08 01:50 EDT by Andre Robatino
Modified: 2014-03-16 23:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-11 11:50:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-04-08 01:50:19 EDT
Description of problem:
Running https://fedoraproject.org/wiki/QA:Testcase_Mediakit_Repoclosure on each of the 15 Beta RC1 DVDs, I get on i386:

Added myrepo repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   myrepo
Num Packages in Repos: 2937
package: xfce-utils-4.8.1-2.fc15.i686 from myrepo
  unresolved deps: 
     xfwm4
package: xfdesktop-4.8.1-3.fc15.i686 from myrepo
  unresolved deps: 
     xfwm4

and on x86_64:

Added myrepo repo from /media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   myrepo
Num Packages in Repos: 2931
package: xfce-utils-4.8.1-2.fc15.x86_64 from myrepo
  unresolved deps: 
     xfwm4
package: xfdesktop-4.8.1-3.fc15.x86_64 from myrepo
  unresolved deps: 
     xfwm4

Version-Release number of selected component (if applicable):
15 Beta RC1
Comment 1 James Laska 2011-04-08 07:25:34 EDT
Qualifies as a beta blocker per the Alpha criteria [1]

   "# There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (CD/DVD) install "

[1] http://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 2 Bruno Wolff III 2011-04-08 10:38:13 EDT
The install ks explicitly excludes xfwm4* from the repo. We either need to exclude more xfce stuff or less. Note that pungi is an inclusive resolver, and will pull in ALL packages that satisfy a dependency.
I don't know where the exact scripts are to run a test build, but it might be worth trying with the addition of --excludes=xfce* since I doubt that any such packages are supposed to be brought in.
Comment 3 Adam Williamson 2011-04-08 10:39:56 EDT
+1, clearly hits the criterion.
Comment 4 Bruno Wolff III 2011-04-08 10:49:56 EDT
It looks like excluding xfce* is a bad idea since @xfce-desktop is specifically included.
I'm going to check the commit log and see if I can find the reason for the exclusion.
Comment 5 Dennis Gilmore 2011-04-08 10:50:44 EDT
We explicitly added xfce and lxde to the install dvd this release. so the exclude line needs removal
Comment 6 Robyn Bergeron 2011-04-08 10:55:07 EDT
+1 for hitting criterion
Comment 7 Bruno Wolff III 2011-04-08 10:58:41 EDT
Here is the info:
http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commitdiff;h=09248faa40eaa2d07fbabf7cef7bd7db05c6e478;hp=6b1bb145d8b380d66c41fd60862e26f8d8a7c68f
The commit description is:
Keep xfce stuff off the media
This is odd in light of @xfce-desktop being included explicitly.
I'd be inclined to just drop those extra excludes.

Considering the proximity in time to the kernel-PAE removal, I think this is likely related to the CD1 being over size issue that came up close to a release and some compromises were made to get things working. I don't remember where I caught glimpses of that discussion, but I'll see if I can find it.
Comment 8 James Laska 2011-04-08 11:01:39 EDT
I'm testing a pungi DVD.iso compose without --exclude xfwm4 ...
Comment 9 Bruno Wolff III 2011-04-08 11:11:55 EDT
This might have been somewhat related to bug 642557, where some stuff needed to get added to the first image of split media. The change to reduce the size happened the next day.
Comment 10 Bruno Wolff III 2011-04-08 11:14:35 EDT
You might also need to drop --exclude xfce4-notifyd as that was added in the same commit as --exclude xfwm4. But if your change works, I wouldn't worry about it more now.

Are we finally dropping split media for this release? I thought I remembered that we were finally going to do that, but I don't know for sure. If we are keeping them, we may need to go back and look for issues there.
Comment 11 Bruno Wolff III 2011-04-08 11:19:27 EDT
This comments in the spin-kickstarts package do indicate the problem for which the excludes were added were related to a split media problem:
* Wed Oct 20 2010 Jesse Keating <jkeating@redhat.com> - 0.14.4-3
  - Include patchs to scrub xfce and more kernel-PAE* from the media
* Tue Oct 19 2010 Jesse Keating <jkeating@redhat.com> 0.14.4-1
  - Fix i386 split CD install media by scrubbing kernel-PAE

We have already reverted the kernel-pae exclusion. If split media is no longer a problem, then I think removing --exclude xfce4-notifyd --exclude xfwm4* should also be done.

I am also going to move this to spin-kickstarts, since that seems to be where this belongs.
Comment 12 Bruno Wolff III 2011-04-08 11:23:59 EDT
It does seem FESCO agreed to drop split media. So I am going to commit a fix to the install kickstart file.
http://meetbot.fedoraproject.org/fedora-meeting/2010-10-20/fesco.2010-10-20-18.30.html
Comment 13 Bruno Wolff III 2011-04-08 11:28:53 EDT
The following commit to spin-kickstarts should resolve this:
http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commit;h=2c5051ad29af8c10905c3d45678c6b8316152e95
Comment 14 James Laska 2011-04-08 11:42:46 EDT
(In reply to comment #13)
> The following commit to spin-kickstarts should resolve this:
> http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=commit;h=2c5051ad29af8c10905c3d45678c6b8316152e95

Applying that commit resolved the issue in my testing.

# mount -o ro,loop /var/lib/mock/fedora-15-i386/root/15/Fedora/i386/iso/Fedora-15-i386-DVD.iso  /media/
# repoclosure --repoid=media --repofrompath=media,file:///media  -t -a noarch -a $(uname -i) -n
Added media repo from file:///media
Reading in repository metadata - please wait....
Checking Dependencies
Repos looked at: 1
   media
Num Packages in Repos: 2941
Comment 15 Andre Robatino 2011-04-09 06:32:33 EDT
15 Beta RC2 DVDs pass repoclosure and file conflicts tests.
Comment 16 James Laska 2011-04-11 07:17:08 EDT
(In reply to comment #15)
> 15 Beta RC2 DVDs pass repoclosure and file conflicts tests.

Thanks Andre!
Comment 17 Adam Williamson 2011-04-11 11:19:43 EDT
should we close the bug, then?

Note You need to log in before you can comment on or make changes to this bug.