Bug 694720 - Clients should use MIME-Version/Content-Type/Content-Transfer-Encoding
Clients should use MIME-Version/Content-Type/Content-Transfer-Encoding
Status: CLOSED DUPLICATE of bug 748727
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
zanata-dev-internal
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-04-08 02:34 EDT by Sean Flanigan
Modified: 2013-03-03 21:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-12 20:28:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2011-04-08 02:34:46 EDT
The Java and Python clients currently assume that all POT/PO files are in UTF-8, ignoring the header fields MIME-Version/Content-Type/Content-Transfer-Encoding.  

These fields should be used to select the correct character encoding when reading POT/PO files.  Also, when generating POT/PO files, we should specify a reasonable value.  I think it's okay to output UTF-8 in all cases, as long as we put the correct encoding into the header.

We should at least check for unsupported encodings when reading, and generate sensible headers when writing.
Comment 1 Sean Flanigan 2011-09-07 00:33:29 EDT
Assigning to Scrum product owner for prioritisation.
Comment 2 Sean Flanigan 2012-02-12 20:28:49 EST

*** This bug has been marked as a duplicate of bug 748727 ***

Note You need to log in before you can comment on or make changes to this bug.