Bug 694850 - Reporters and user should be able to control which fields are reported
Summary: Reporters and user should be able to control which fields are reported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Denys Vlasenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-08 15:36 UTC by Steve Tyler
Modified: 2011-09-26 18:30 UTC (History)
8 users (show)

Fixed In Version: abrt-2.0.3-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:24:07 UTC


Attachments (Terms of Use)

Description Steve Tyler 2011-04-08 15:36:09 UTC
Description of problem:
Abrt records events and errors during bug processing in a file called event_log. This file is attached as part of the bug report, but it should not be, because it is not relevant to the bug itself.

Version-Release number of selected component (if applicable):
abrt-2.0.0-4.fc15.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Submit a bug to bugzilla.
  
Actual results:
One of the attachments is "File: event_log".
Example: Bug 693979.

Expected results:
No such attachment.

Additional info:
The report_Logger plugin writes a file that has an event_log section.

Bug 694296 - report_Logger does not append last report event in event_log section of report

[Copied from Bug 694296, Comment 1]
This is just a confusing name of the reporter you used, so I try to explain:

event_log is a file where we store the std output from all applications run
during some event (analyzing, reporting) the log file created by report_Logger
is a place where it stores the report and thus the line "report was stored"
doesn't belong there. From ABRT's view the /tmp/abrtX.log is the same as
bugzilla so that's why it stores there only the "report data". I know that now
you can see event_log even in bugzilla, but that's just another bug in the
bugzilla reporter.

Comment 1 Denys Vlasenko 2011-04-27 17:26:36 UTC
Renaming from

event_log should not be included in bug report

to

Reporters and user should be able to control which fields are reported

Comment 2 Steve Tyler 2011-04-27 21:21:16 UTC
(In reply to comment #1)
...
> Reporters and user should be able to control which fields are reported

That's good idea.

Comment 3 Denys Vlasenko 2011-05-03 11:26:39 UTC
Comment from https://fedorahosted.org/abrt/ticket/226

As mentioned in Ticket #225, it would be nice to be able to tell abrt what to send with the user's report. Right now are sent about 6 attachments (I was told it's a known bug). I suggest to add some simple way to configure abrt from the package what should be send and what not. For me I mainly watch only the backtrace, I do not care about anything else.

I guess adding list "what-to-send" is better than "what-not-to-send", because when some user request new data for gathering then other may not change their definitions unless also interested in the new data.

Comment 4 Steve Tyler 2011-05-03 16:01:56 UTC
(In reply to comment #3)
> Comment from https://fedorahosted.org/abrt/ticket/226
> 
> As mentioned in Ticket #225, it would be nice to be able to tell abrt what to
> send with the user's report. Right now are sent about 6 attachments (I was told
> it's a known bug). I suggest to add some simple way to configure abrt from the
> package what should be send and what not. For me I mainly watch only the
> backtrace, I do not care about anything else.

That is a good idea, since developers would know best what information is useful.

If a developer needs more information accessible to ABRT than what is normally sent, how would the user provide it?
(Without sending email: Bug 692590, Comment 8)

> I guess adding list "what-to-send" is better than "what-not-to-send", because
> when some user request new data for gathering then other may not change their
> definitions unless also interested in the new data.

Comment 5 Steve Tyler 2011-05-03 16:04:40 UTC
(In reply to comment #4)
> (In reply to comment #3)
...
> (Without sending email: Bug 692590, Comment 8)

BTW, I was fully aware that I was compromising my BZ password when I sent that.

Comment 6 Denys Vlasenko 2011-05-24 17:58:39 UTC
Added checkboxes to problem details treeview:

commit 2e1d04e7dd85551e9d33c51bbd6008ac9b1b84c1
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Tue May 24 19:45:35 2011 +0200

    wizard: make checkbox column editable. Has no effect for now

commit 792ed110c06aa8a4b4acfded5226bee3a8008353
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Tue May 24 19:45:11 2011 +0200

    wizard: add checkbox cloumn to details view


Now need to add code to pass this data to reporters...

Comment 7 Denys Vlasenko 2011-06-01 16:05:56 UTC
Fixed in git by this commit:

commit 2fa751f6d98995e73db4d0edd0d22b9560281644
Author: Denys Vlasenko <dvlasenk@redhat.com>
Date:   Wed Jun 1 17:57:31 2011 +0200

    wizard: hook selection checkboxes to reporters.

    Checkboxes are controlled by the following elements in .xml:

    <requires-items> ITEM1,ITEM2 </requires-items>
    <exclude-items-by-default> ITEM1,ITEM2 </exclude-items-by-default>
    <exclude-items-always> ITEM1,ITEM2 </exclude-items-always>
    <exclude-binary-items> yes / no </exclude-binary-items>
    <include-items-by-default> ITEM1,ITEM2 </include-items-by-default>

    exclude-items-by-default and exclude-items-always can be "*"
    meaning "all". include-items-by-default specifies which items
    are included (checked) is exclude-items-by-default is "*".
    Else, all are checked by default.

    the set of iters NOT included is passed in $EXCLUDE_FROM_REPORT
    variable. bugzilla, kerneloops, mailx, print and rhtsupport
    are made aware of this variable.

Comment 8 Fedora Update System 2011-06-21 13:44:01 UTC
abrt-2.0.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15

Comment 9 Fedora Update System 2011-06-21 23:55:02 UTC
Package abrt-2.0.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/abrt-2.0.3-1.fc15
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-06-24 03:22:00 UTC
abrt-2.0.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Milan Crha 2011-09-26 18:30:43 UTC
(In reply to comment #7)
>     Checkboxes are controlled by the following elements in .xml:
> 
>     <requires-items> ITEM1,ITEM2 </requires-items>
>     <exclude-items-by-default> ITEM1,ITEM2 </exclude-items-by-default>
>     <exclude-items-always> ITEM1,ITEM2 </exclude-items-always>
>     <exclude-binary-items> yes / no </exclude-binary-items>
>     <include-items-by-default> ITEM1,ITEM2 </include-items-by-default>

What is the XML and where should I install it within my package, please? I do not seem to get it from the commit log message, I'm sorry (I got to this slightly later than expected).


Note You need to log in before you can comment on or make changes to this bug.