Bug 694890 - fails to work properly on x86_64 perhaps due to old gdb source bundled/hidden in the build
Summary: fails to work properly on x86_64 perhaps due to old gdb source bundled/hidden...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: insight
Version: 14
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Patrick Monnerat
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 702648
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-04-08 18:37 UTC by Jack Perdue
Modified: 2012-05-02 20:56 UTC (History)
4 users (show)

Fixed In Version: insight-7.4.50-1.20120403cvs.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-22 03:48:47 UTC
Type: ---


Attachments (Terms of Use)

Description Jack Perdue 2011-04-08 18:37:49 UTC
Description of problem:

See: http://forums.fedoraforum.org/showthread.php?t=261192

<quote>
When I try to see local variables, i see that:
a = (int) Could not read variable object value after assigment
...

in terminal screen I have:

BFD: /lib64/libc.so.6: invalid relocation type 37
BFD: BFD (GNU Binutils) 2.18.50.20080226 assertion fail elf64-x86-64.c:278
BFD: /lib64/libc.so.6: invalid relocation type 37
BFD: BFD (GNU Binutils) 2.18.50.20080226 assertion fail elf64-x86-64.c:278
</quote>

http://forums.fedoraforum.org/showthread.php?t=261192


Version-Release number of selected component (if applicable):

insight-6.8.1-3.fc14.x86_64

I also tried the insight from Fedora 13 and 15-Alpha

How reproducible:

Easy.


Steps to Reproduce:
1. See forum link

  
Actual results:
See forum link


Expected results:
A display of the local variables and their values.

Additional info:

It would appear Debian has given up on trying to separate all the bundled source from the core insight code and therefore dropped the package:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566579

Although it appears Patrick has made some valiant efforts in removing most of those dependencies, it would seem that there still exists old gdb code to deal with.  

Is there a need for a debugger based on an older gdb code base?  If so, then this packages %description should be updated to indicate that it is based on old gdb and that newer interactive debuggers like ddd or nemiver are available and work better on modern code.

ddd and nemiver both seem to use the installed gdb.  Is there an easy way to make insight do that?  If not, and if there is no need for an older gdb interface, given a lack of activity upstream, maybe it is worth just dropping the package altogether (if only to save people any time they might waste on it).

Perhaps there is a simple fix to the lack of local variable display on 64-bit x86, but bundling gdb source seems to violate the packaging guidelines.... it would be better if it was based on a more modern gdb.

Comment 1 Patrick Monnerat 2011-04-11 13:33:10 UTC
Thanks for the report. Here are the points on which I'd like to add some precisions:
1) The insight home page does not show recent activity, as you have noted, but forum at http://old.nabble.com/Sourceware---insight-f12222.html and CVS at http://sourceware.org/cgi-bin/cvsweb.cgi/src/gdb/gdbtk/?cvsroot=src do. I've been expecting a new upstream release for quite a long time: an alternative would be to produce a new Fedora release from CVS... will perhaps be better for 64bit, but unstable by definition.
2) The only bundled library with this package is libgui: it has no home page, no serious doc, but only an entry in CVS. In addition, the only other product using it is srcnav2 (not ported to Fedora), AFAIK. All other libraries (tcl, tk, itcl, itk, iwidgets, readline) have been unbundled. I may once consider the effort to unbundle libgui, but this probably will be useless.
3) gdb is NOT a bundle: insight modifies the base code to create a new product. gdb is NOT a library and as such, cannot be linked with the insight code. This is not feasible by design.
4) I do not know nemiver, but I have to say ddd has a lot of problem, and had them for a long time now. From my point of view, it is less usable than insight. Since insight is a RedHat product and although Keith Seitz, its main maintainer predicts its end of life soon, I do not think dropping it now like the other distros did is a good idea.

I'll investigate your local variable problem.

Comment 2 Patrick Monnerat 2011-05-18 10:12:59 UTC
OK: I've succeeded in producing a patched version that shows local variables on x86_64, but I can't release it through Koji+Bodhi because it requires a change to the binutils package (see blockers). For the same reason, you won't be able to compile it using the official binutils package.
For an official update, we have to wait for the blocker's resultion. In the meantime, you can find an unofficial patched binary version of insight at http://monnerat.fedorapeople.org/insight-6.8.1-4.fc14.x86_64.rpm

Comment 3 gene smith 2011-11-30 22:39:10 UTC
Tried the unofficial version but it only seemed to fix the errors (warnings?) printed to terminal. With -4 and the official -3 version for fc14.x86_64, I see code as though it were highly optimized with "step points" visible on only a few instructions. Same program works fine when debugged with GDB so there must be something still wrong. GCC flag -m32 made no difference.
I tried Nemiver and it works OK. However, there is still a lot I like with the Insight interface better. Anything beats trying to debug with raw GDB!

Comment 4 Fedora Update System 2012-04-10 14:54:06 UTC
insight-7.4.50-1.20120403cvs.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/insight-7.4.50-1.20120403cvs.fc16

Comment 5 Fedora Update System 2012-04-11 03:51:00 UTC
Package insight-7.4.50-1.20120403cvs.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing insight-7.4.50-1.20120403cvs.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5626/insight-7.4.50-1.20120403cvs.fc16
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-04-19 12:23:54 UTC
insight-7.4.50-1.20120403cvs.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/insight-7.4.50-1.20120403cvs.fc17

Comment 7 Fedora Update System 2012-04-22 03:48:47 UTC
insight-7.4.50-1.20120403cvs.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2012-05-02 20:56:42 UTC
insight-7.4.50-1.20120403cvs.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.