Bug 694892 - Non-Perm user error loading about box
Non-Perm user error loading about box
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2011-04-08 14:51 EDT by Jay Shaughnessy
Modified: 2011-12-05 11:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Shaughnessy 2011-04-08 14:51:41 EDT
1) In a new browser window login as a user without MANAGE_SETTINGS permission

This generates an exception on login because the About Box info failed to load.
Comment 1 Jay Shaughnessy 2011-04-08 15:44:08 EDT
Fix commit: 0589b9ee8488bd1

Added new remote method SystemManagerRemote.getProductInfo() to support non-perm pull of the necessary data.
Comment 2 Sunil Kondkar 2011-05-06 03:37:23 EDT
Verified on rhq4 release build (Version: 4.0.0 Build Number: db0c817)

Logged in as a user without MANAGE_SETTINGS permission in a new browser window. The sever log does not display any exception.

Marking as verified.
Comment 3 Corey Welton 2011-05-23 21:17:58 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:17:58 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:17:59 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:18:02 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.