Bug 694932 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-08 19:18 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-24 00:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnsmasq-2.58-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-28 15:39:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for dnsmasq (245 bytes, text/plain)
2011-04-08 19:18 EDT, Jóhann B. Guðmundsson
no flags Details
Dbus enabled unit. (251 bytes, text/plain)
2011-07-26 08:39 EDT, Jóhann B. Guðmundsson
no flags Details
Spec file patch for dnsmasq (1.92 KB, patch)
2011-07-26 15:22 EDT, Jóhann B. Guðmundsson
no flags Details | Diff

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-08 19:18:45 EDT
Created attachment 490889 [details]
Native systemd service file for dnsmasq

Description of problem:

Let's get this party started since it's Friday ;) 

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2011-04-26 13:35:34 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 2 Jóhann B. Guðmundsson 2011-06-29 06:14:28 EDT
What's the current status on this?

We need this in rawhide as soon as possible unless ofcourse you guys want to
block alpha.. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 3 Jóhann B. Guðmundsson 2011-07-18 05:11:17 EDT
I'm going to start initiating non-responsive packaging policy 

Maintainer not listed on vacation and no response et all from maintainer on this bug report note this component is part of default live cd thus will end up blocking the alpha release.. 

http://fedoraproject.org/wiki/Policy_for_nonresponsive_package_maintainers
Comment 4 Jóhann B. Guðmundsson 2011-07-26 08:39:43 EDT
Created attachment 515269 [details]
Dbus enabled unit.

Note that you will need add enable-dbus to /etc/dnsmasq.conf

starts and stops cleanly 

Jul 26 12:38:04 valhalla dnsmasq[10032]: started, version 2.52 cachesize 150
Jul 26 12:38:04 valhalla dnsmasq[10032]: compile time options: IPv6 GNU-getopt DBus no-I18N DHCP TFTP
Jul 26 12:38:04 valhalla dnsmasq[10032]: DBus support enabled: connected to system bus

# netstat -pant | grep :53
tcp        0      0 0.0.0.0:53                  0.0.0.0:*                   LISTEN      10032/dnsmasq       
tcp        0      0 :::53                       :::*                        LISTEN      10032/dnsmasq
Comment 5 Jóhann B. Guðmundsson 2011-07-26 15:22:45 EDT
Created attachment 515351 [details]
Spec file patch for dnsmasq

After speaking with Dan in irc we should not use the dbus unit hence deprecating it
Comment 6 Fedora Admin XMLRPC Client 2011-08-22 14:31:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Douglas Schilling Landgraf 2011-08-28 15:39:24 EDT
The attached patches were commited and F16 alpha released. I am closing this BZ for now, fell free to open it again if required. Thanks for the patches.

commit a4a3c3269d60960a3cabeb78c4f9c5bf2116843d
Author: Patrick Laughton <jima@fedoraproject.org>
Date:   Mon Aug 8 16:21:55 2011 -0500

    Applied Jóhann's patch, minor cleanup
    
    * Thu Jul 26 2011 Jóhann B. Guðmundsson <johannbg@gmail.com> - 2.52-3
    - Introduce systemd unit file, drop SysV support


Cheers
Douglas
Comment 8 Jóhann B. Guðmundsson 2011-08-28 18:11:59 EDT
Uhum arent you going to build this for F16?
Comment 9 Fedora Update System 2011-08-29 14:25:23 EDT
dnsmasq-2.58-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dnsmasq-2.58-1.fc16
Comment 10 Douglas Schilling Landgraf 2011-08-29 14:28:07 EDT
Hello Jóhann,

   I have closed that BZ since the changes were committed to rawhide but I have submitted a package update to F16 right now:

https://admin.fedoraproject.org/updates/dnsmasq-2.58-1.fc16

Thanks again for your work. Please let me know if there is any pending change/update from my side.

Cheers
Douglas
Comment 11 Fedora Update System 2011-09-15 22:06:17 EDT
dnsmasq-2.58-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dnsmasq-2.58-2.fc16
Comment 12 Fedora Update System 2011-09-24 00:38:17 EDT
dnsmasq-2.58-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.