Bug 694940 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: irda-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dmitry Butskoy
Fedora Extras Quality Assurance
:
: 714685 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-04-08 20:05 EDT by Jóhann B. Guðmundsson
Modified: 2011-07-18 10:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-18 10:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for irda (284 bytes, text/plain)
2011-04-08 20:05 EDT, Jóhann B. Guðmundsson
no flags Details
New more correct irda.service (289 bytes, text/plain)
2011-07-15 14:08 EDT, Jóhann B. Guðmundsson
no flags Details
New irda.service (333 bytes, text/plain)
2011-07-15 14:33 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-04-08 20:05:24 EDT
Created attachment 490897 [details]
Native systemd service file for irda

Description of problem:

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see [4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2011-04-26 13:35:51 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 2 Jóhann B. Guðmundsson 2011-06-20 08:51:14 EDT
*** Bug 714685 has been marked as a duplicate of this bug. ***
Comment 3 Jóhann B. Guðmundsson 2011-06-27 09:50:58 EDT
What's the current status on this?

We need this in rawhide as soon as possible unless ofcourse you guys want to
block alpha.. 

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
http://fedoraproject.org/wiki/Packaging:Tmpfiles.d
Comment 4 Karsten Hopp 2011-07-04 06:46:51 EDT
irda-utils has been orphaned some time ago and won't be in F16 unless someone picks it up as a maintainer
Comment 5 Jóhann B. Guðmundsson 2011-07-04 07:03:03 EDT
Flagged as orphaned here.. https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd

Is @base group auto generated as in when package is orphaned does it automatically get removed from @base?
Comment 6 Fedora Admin XMLRPC Client 2011-07-15 08:16:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Jóhann B. Guðmundsson 2011-07-15 11:11:27 EDT
Noticed that this got picked up again it would be good you ( the new maintainer ) could package the unit file according to the packaging guidelines since this component is part of the Base group thus will block the alpha release.

Thanks..
Comment 8 Dmitry Butskoy 2011-07-15 13:56:45 EDT
Well,

The attached file is not good (it does not use settings from /etc/sysconfig/irda, as well this file seems not to be a pidfile...)

Moreover, the variables from /etc/sysconfig/irda was prepared some way in sysv init file, but I have not found any current example how another packages (with similar preparations) handle this now under systemd. For example, bind, samba still not have systemd service files.

The problem is I would like to use "-d $DONGLE" in the cmdline only when DONGLE set, and do not use "-d" if it is not set. Certainly I can cause "-d" to go to the variable immediately (ie. DONGLE="-d something"), but I'm not sure whether it is a good design to cause end users (simple sysadmins) to remember that they must preserve "-d" before tha name...

Is it applicable to use irda-utils under SysV, at least for a while?
Comment 9 Jóhann B. Guðmundsson 2011-07-15 14:08:24 EDT
Created attachment 513427 [details]
New more correct irda.service
Comment 10 Jóhann B. Guðmundsson 2011-07-15 14:18:20 EDT
(In reply to comment #8)
> Well,
> 
> The attached file is not good (it does not use settings from
> /etc/sysconfig/irda, as well this file seems not to be a pidfile...)

Not my finest work I must admit.. 
 
> Moreover, the variables from /etc/sysconfig/irda was prepared some way in sysv
> init file, but I have not found any current example how another packages (with
> similar preparations) handle this now under systemd. For example, bind, samba
> still not have systemd service files.

Well bind and samba have native systemd unit files they are just stuck in bugzilla like so many others ( around 200 I believe ) 

> 
> The problem is I would like to use "-d $DONGLE" in the cmdline only when DONGLE
> set, and do not use "-d" if it is not set. Certainly I can cause "-d" to go to
> the variable immediately (ie. DONGLE="-d something"), but I'm not sure whether
> it is a good design to cause end users (simple sysadmins) to remember that they
> must preserve "-d" before tha name...
> 
> Is it applicable to use irda-utils under SysV, at least for a while?

Not since this is part of Base worst case scenario we have a workaround for that but why not have two unit files one for dongle and the other one not? 

irda.service
irda-dongle.service 

?
Comment 11 Jóhann B. Guðmundsson 2011-07-15 14:33:24 EDT
Created attachment 513428 [details]
New irda.service

Adding syslog to the mix since could not notice why the service was failing.. 

Basically I cant test this since I dont have the required hw hence the service fails with.. 

Jul 15 18:30:10 valhalla irattach: tcgetattr: Input/output error
Jul 15 18:30:10 valhalla irattach: Stopping device /dev/ttyS2
Jul 15 18:30:10 valhalla irattach: ioctl(SIOCGIFFLAGS): No such device
Jul 15 18:30:10 valhalla irattach: exiting ...
Comment 12 Jóhann B. Guðmundsson 2011-07-15 14:37:54 EDT
Try the newly submitted file and I should mention that you probably should stuff the loading of the modules into irda.conf file since modules should be loaded via autoloading based on bus information, or via /etc/modules-load.d/*.conf. and unloading a module from the kernel should not be done except for debugging purposes afaik..
Comment 13 Dmitry Butskoy 2011-07-18 10:51:19 EDT
Done in rawhide.

Note You need to log in before you can comment on or make changes to this bug.