Bug 694979 - [abrt] control-center-3.0.0.1-3.fc15: g_settings_schema_get_value: Process /usr/bin/gnome-control-center was killed by signal 6 (SIGABRT)
Summary: [abrt] control-center-3.0.0.1-3.fc15: g_settings_schema_get_value: Process /u...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:30a52a0216c3e822df6b2abbc4a...
Keywords:
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-04-09 11:27 UTC by Lukas Bezdicka
Modified: 2011-04-17 01:21 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-04-15 03:13:57 UTC


Attachments (Terms of Use)
File: event_log (20.12 KB, text/plain)
2011-04-09 11:27 UTC, Lukas Bezdicka
no flags Details
File: maps (71.37 KB, text/plain)
2011-04-09 11:27 UTC, Lukas Bezdicka
no flags Details
File: dsos (55.52 KB, text/plain)
2011-04-09 11:27 UTC, Lukas Bezdicka
no flags Details
File: backtrace (35.21 KB, text/plain)
2011-04-09 11:27 UTC, Lukas Bezdicka
no flags Details

Description Lukas Bezdicka 2011-04-09 11:27:33 UTC
abrt version: 2.0.0
comment: user>system settings>keyboard = crash
package: control-center-3.0.0.1-3.fc15
cmdline: gnome-control-center --overview
component: control-center
executable: /usr/bin/gnome-control-center
crash_function: g_settings_schema_get_value
kernel: 2.6.38.2-9.fc15.x86_64
architecture: x86_64
reason: Process /usr/bin/gnome-control-center was killed by signal 6 (SIGABRT)
uid: 500
username: social
os_release: Fedora release 15 (Lovelock)
time: 1302347395
rating: 4

Text file: event_log, 20602 bytes
Text file: maps, 73084 bytes
Binary file: smaps, 324608 bytes
Binary file: coredump, 25595904 bytes
Text file: dsos, 56850 bytes
Text file: backtrace, 36051 bytes

Comment 1 Lukas Bezdicka 2011-04-09 11:27:36 UTC
Created attachment 490947 [details]
File: event_log

Comment 2 Lukas Bezdicka 2011-04-09 11:27:40 UTC
Created attachment 490948 [details]
File: maps

Comment 3 Lukas Bezdicka 2011-04-09 11:27:43 UTC
Created attachment 490949 [details]
File: dsos

Comment 4 Lukas Bezdicka 2011-04-09 11:27:46 UTC
Created attachment 490950 [details]
File: backtrace

Comment 5 Lukas Bezdicka 2011-04-09 11:30:50 UTC
$ gnome-control-center 

GLib-GIO-ERROR **: Settings schema 'org.gnome.settings-daemon.peripherals.keyboard' does not contain a key named 'repeat-interval'
aborting...
Aborted (core dumped)

Comment 6 Leif H. Asgeirsson 2011-04-09 18:18:03 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Open gnome-control-center and click on 'Keyboard'. Process is terminated immediately. The same thing happens if you open the keyboard settings directly ('gnome-control-center keyboard').

Comment 7 skibum1981 2011-04-13 09:13:24 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Just selected "keyboard settings" from applications and it crashed... problem recurs.  Have never been able to launch keyboard settings.

Comment 8 gabicr 2011-04-13 11:50:52 UTC
running gnome-control-center keyboard from console raise:


Gtk-Message: Failed to load module "pk-gtk-module"

GLib-GIO-ERROR **: Settings schema 'org.gnome.settings-daemon.peripherals.keyboard' does not contain a key named 'repeat-interval'
aborting...
Aborted (core dumped)

Comment 9 d. johnson 2011-04-13 19:51:12 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
gnome-control-center, click on keyboard.

Comment 10 Matt Cockayne 2011-04-14 06:54:52 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Was trying to access the keboard panel in conrtrol center.

Comment 11 Jim Helm 2011-04-14 07:46:05 UTC
As a temporary workaround (I assume, until the control center code is updated to not try to read that key) I duplicated the "delay" key in the file below, and changed the key name to repeat-interval.

/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.gschema.xml

Then I recompiled the schemas with 

glib-compile-schemas /usr/share/glib-2.0/schemas

This got the keyboard settings working under the control center.

Comment 12 Kenneth Holmqvist 2011-04-14 09:21:54 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
i tried to open keyboard configuration and then it crashed.

Comment 13 gabicr 2011-04-14 12:09:39 UTC
Thanks Jim!

Comment 14 Robert Swain 2011-04-15 00:05:58 UTC
Package: control-center-3.0.0.1-3.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Opened System Settings, clicked on Keyboard.

Comment 15 Matthias Clasen 2011-04-15 03:13:57 UTC
This is fixed in the current version of gsettings-desktop-schemas, 3.0.0

Comment 16 cgrim 2011-04-15 14:08:13 UTC
I have gsettings-desktop-schemas-3.0.0-2.fc15 installed and facing this problem, but in koji there is no newer version. Matthias please where can I get newer version of gsettings-desktop-schemas you spoke about? 

Thanks Lukas

Comment 17 Matthias Clasen 2011-04-15 15:27:17 UTC
What does 

 grep repeat-interval /usr/share/glib-2.0/schemas/*

say ?

Comment 18 Rahul Sundaram 2011-04-16 01:33:56 UTC
Returns nothing on my system

Comment 19 Bruce O. Benson 2011-04-16 05:32:13 UTC
This bug remains after a fresh install and update from Updates and Updates Testing...
# rpm -qa | grep gsettings
gsettings-desktop-schemas-3.0.0-2.fc15.noarch

Please reopen, advise or redirect.  Thanks.

Comment 20 Bryn M. Reeves 2011-04-16 10:17:40 UTC
$ rpm -q gsettings-desktop-schemas
gsettings-desktop-schemas-3.0.0-2.fc15.noarch

$ grep -r repeat-interval /usr/share/glib-2.0/schemas/ | wc -l
0

$ cd /usr/share/glib-2.0/schemas/
$ grep -r 'Key repeat' .
./org.gnome.settings-daemon.peripherals.gschema.xml:      <description>Key repeat rate in milliseconds.</description>
./org.gnome.settings-daemon.peripherals.gschema.xml:      <description>Key repeat delay in milliseconds.</description>

$ rpm -qf org.gnome.settings-daemon.peripherals.gschema.xml 
gnome-settings-daemon-2.91.93-2.fc15.x86_64

Comment 21 Bryn M. Reeves 2011-04-16 10:44:18 UTC
Updated to gnome-settings-daemon-3.0.0.1-1 from koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=237849

$ rpm -q gnome-settings-daemon
gnome-settings-daemon-3.0.0.1-1.fc15.x86_64

$ grep -r repeat-interval /usr/share/glib-2.0/schemas/
/usr/share/glib-2.0/schemas/org.gnome.settings-daemon.peripherals.gschema.xml:    <key type="u" name="repeat-interval">
Binary file /usr/share/glib-2.0/schemas/gschemas.compiled matches

gnome-control-center no longer crashes when selecting the keyboard applet (and more importantly I have working key repeat..;).

Changed component & set fixed in release.

Comment 22 Jim Helm 2011-04-17 01:19:27 UTC
I don't beleive that was that correct fix - you've fixed a side-effect, not the root cause.  It *does* prevent the control center from crashing, but changes to the control center for "Speed" have no effect, and do not change the values of either the rate or repeat-interval values as reported by gsettings.  Changes to delay however, do work.

[jhelm@lorelei: /home/jhelm ]
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard repeat-interval
500
[jhelm@lorelei: /home/jhelm ]
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard rate
30

<adjust value in control-center gui>
<no change to repeat rate observed in use or in stored settings>

[jhelm@lorelei: /home/jhelm ]
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard repeat-interval
500
[jhelm@lorelei: /home/jhelm ]
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard rate           
30

[jhelm@lorelei: /home/jhelm ]
$ gsettings set org.gnome.settings-daemon.peripherals.keyboard rate 200

<observed change in repeat rate in use and in stored settings>

[jhelm@lorelei: /home/jhelm ]
$ gsettings get org.gnome.settings-daemon.peripherals.keyboard rate    
200

Using the control center gui to make changes to "delay" does work, reflected both in use, and in the stored settings.

Comment 23 Jim Helm 2011-04-17 01:21:06 UTC
I retract my last comment... I do not (yet) have the updated settings daemon installed.


Note You need to log in before you can comment on or make changes to this bug.