Bug 6950 - /sbin/restore fails to restore full dump
Summary: /sbin/restore fails to restore full dump
Status: CLOSED DUPLICATE of bug 5923
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-12 11:42 UTC by eda
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 18:50:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description eda 1999-11-12 11:42:14 UTC
/sbin/restore fails to restore full dump of 1GB ext2 filesystem. Has
trouble mostly with symlinks and special files.

The bug can be reproduced as follows:

mount /dev/sda4 /sda4
cd /sda4
dump 0f - /dev/sda1 | restore xf -

IMHO this problem is serious enough to be solved ASAP by RedHat.

It appears that the 0.4b7-1 abd 0.4.b9-1 dump rpm taken from developer's
web pages do not exhibit this problem.

It is not very nice from RedHat to leave users making regular backups
without fully functional restore. Of course, this is not fatal problem if
you have working system and can easily upgrade dump, but it is much serious
disaster if system disk crashes and user is left with tape backup, new disk
drive and boot diskettes only.

Brgds and thanks,

Eduard Vopicka

Comment 1 Bill Nottingham 2000-02-05 18:50:59 UTC
*** This bug has been marked as a duplicate of 5923 ***


Note You need to log in before you can comment on or make changes to this bug.