Bug 695047 - when timezone is changed during phase, getting traceback on phase end
when timezone is changed during phase, getting traceback on phase end
Status: CLOSED DUPLICATE of bug 693653
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
14
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 545868
  Show dependency treegraph
 
Reported: 2011-04-10 01:48 EDT by Jan Hutař
Modified: 2016-09-19 22:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-11 08:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2011-04-10 01:48:28 EDT
Description of problem:
When I change timezone to more west one by rewriting /etc/timezone during execution of phase, on the phase end I'm getting traceback.


Version-Release number of selected component (if applicable):
beakerlib-1.3-4.el5
python-2.4.3-43.el5
tzdata-2011d-3.el5


How reproducible:
always


Steps to Reproduce:
1. # date
Sun Apr 10 07:44:31 CEST 2011
2. # rlJournalStart 
3. # rlPhaseStartTest

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: Test
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

4. # rlRun "/bin/cp -f /usr/share/zoneinfo/UTC /etc/localtime"
:: [   PASS   ] :: Running '/bin/cp -f /usr/share/zoneinfo/UTC /etc/localtime'
5. # rlPhaseEnd


Actual results:
Traceback (most recent call last):
  File "/usr/bin/beakerlib-journalling", line 468, in ?
    createLog(options.testid, options.severity)
  File "/usr/bin/beakerlib-journalling", line 181, in createLog
    printPhaseLog(nod,severity)
  File "/usr/bin/beakerlib-journalling", line 94, in printPhaseLog
    duration = time.mktime(time.strptime(endtime,timeFormat)) - time.mktime(time.strptime(starttime,timeFormat))
  File "/usr/lib/python2.4/_strptime.py", line 293, in strptime
    raise ValueError("time data did not match format:  data=%s  fmt=%s" %
ValueError: time data did not match format:  data=2011-04-10 07:44:46 CEST  fmt=%Y-%m-%d %H:%M:%S %Z


Expected results:
Should show correct output including correct duration
Comment 1 Petr Muller 2011-04-11 08:27:49 EDT

*** This bug has been marked as a duplicate of bug 693653 ***

Note You need to log in before you can comment on or make changes to this bug.